bytes_data_builder 0.1.4

  • Installing
  • Versions
  • 0

bytes_data_builder #

Builds a list of bytes, allowing bytes, fixed-width integers, floats and lists of bytes to be added at the end.

Usage #

A simple usage example:

import 'package:bytes_data_builder/bytes_data_builder.dart';

main() {
  BytesDataBuilder builder = new BytesDataBuilder();
  List<int> result = builder.takeBytes();

Changelog #

0.1.1 #

  • Initial version, created by Kurt Morris

0.1.2 #

  • Mistake corrected in

0.1.3 #

  • replaced with proper change log.

0.1.4 #

  • Added GitHub Repository, made description more aesthetically pleasing.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bytes_data_builder: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bytes_data_builder/bytes_data_builder.dart';
Version Uploaded Documentation Archive
0.1.4 Oct 4, 2016 Go to the documentation of bytes_data_builder 0.1.4 Download bytes_data_builder 0.1.4 archive
0.1.3 Oct 3, 2016 Go to the documentation of bytes_data_builder 0.1.3 Download bytes_data_builder 0.1.3 archive
0.1.2 Oct 3, 2016 Go to the documentation of bytes_data_builder 0.1.2 Download bytes_data_builder 0.1.2 archive
0.1.1 Oct 3, 2016 Go to the documentation of bytes_data_builder 0.1.1 Download bytes_data_builder 0.1.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0