calc_core 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new49

Calculator core

This is a basic calculator logic to show how to separeta logic from front-ent.

This could be used for cli, web or Flutter application.

To see the Flutter app, see the flutter_calc project.

1.0.1

Sanitizing project files:

  • CHANGELOG.md
  • example/readme.md

1.0.0

Basic operations support: sum, subtract, product and division

example/readme.md

Examples

Example for Number class: number.dart Example for Calc class: calc.dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  calc_core: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:calc_core/calc.dart';
import 'package:calc_core/number.dart';
  
Version Uploaded Documentation Archive
1.0.1 Nov 25, 2018 Go to the documentation of calc_core 1.0.1 Download calc_core 1.0.1 archive
1.0.0 Nov 25, 2018 Go to the documentation of calc_core 1.0.0 Download calc_core 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
4
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Health issues and suggestions

Document public APIs (-9.51 points)

39 out of 41 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0