calendar 0.0.3

  • Installing
  • Versions
  • 28

Calendar package for Flutter

A calendar package forFlutter

Getting Started

new Calendar(
    new Item(
      "Item 1", 
      new LatLng(0.0, 0.0), 
  (Item i) => {render}
  new Center(
    child: new Text("No results"),
  title: "hello",
  dateFormat: DateFormat.English,


[0.0.3] - Added today text in tab

[0.0.2] - Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  calendar: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:calendar/calendar.dart';
Version Uploaded Documentation Archive
0.0.3 Oct 22, 2017 Go to the documentation of calendar 0.0.3 Download calendar 0.0.3 archive
0.0.2 Oct 22, 2017 Go to the documentation of calendar 0.0.2 Download calendar 0.0.2 archive
0.0.1 Oct 22, 2017 Go to the documentation of calendar 0.0.1 Download calendar 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Document public APIs (-9.67 points)

29 out of 30 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Fix lib/calendar.dart. (-0.50 points)

Analysis of lib/calendar.dart reported 1 hint:

line 56 col 7: 'child' is deprecated and shouldn't be used.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is getting outdated. (-12.05 points)

The package was released 58 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use calendar.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^0.12.0