A compiler/patcher for a JS bridge to your Dart library, using dart2js and analyzer.
Even though calzone.dart is reaching maturity, if you're interested in using it and are having problems using it, please contact mbullington on the Dart Slack.
The best example of this is in the calzone.transformers library, which is our standard library for transformers. Most of these transformers are suggested for use, such as Promises <-> Future, Closure, and Collections.
Add this to your package's pubspec.yaml file:
dependencies: calzone: ^0.4.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:calzone/analysis.dart'; import 'package:calzone/builder.dart'; import 'package:calzone/compiler.dart'; import 'package:calzone/patcher.dart'; import 'package:calzone/transformers.dart'; import 'package:calzone/util.dart'; import 'package:calzone/visitor_typescript.dart';
|0.4.0||Dec 11, 2017|
|0.3.0||Apr 6, 2017|
|0.2.1||Aug 27, 2016|
|0.2.0||Aug 27, 2016|
|0.1.8||Jul 6, 2016|
|0.1.7||Feb 19, 2016|
|0.1.6||Feb 4, 2016|
|0.1.5||Dec 24, 2015|
|0.1.4||Dec 24, 2015|
|0.1.3||Dec 23, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.10.0 <2.0.0|