carousel 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 45

Carousel

A Flutter simple Carousel Widget.

Usage

As simple as using any flutter Widget. The Carousel package hides all the complexity (almost none, it's Flutter!) of implementing a carousel.

<b>Example:</b> First things first, add the module to your project pubspec.yaml:

...
dependencies:
 ...
 carousel: ^0.0.1
...

And install it using flutter packages get on your project folder. After that, just import the module and use it:

import 'package:carousel/carousel.dart';

//...
new SizedBox(
  height: 240.0,
  child: new Carousel(
    children: [
      new NetworkImage('https://pbs.twimg.com/profile_images/760249570085314560/yCrkrbl3_400x400.jpg'),
      new NetworkImage('https://webinerds.com/app/uploads/2017/11/d49396_d9c5d967608d4bc1bcf09c9574eb67c9-mv2.png')
    ].map((netImage) => new Image(image: netImage)).toList(),
  ),
)


This code snippet creates an Carousel with an height of 240.0 that contains both the logos of Flutter and React native, as an example. Simples as that! 😄

Credits

Developed by Gabriel Valério gbrvalerio@gmail.com

Contributing

Feel free to help!

[0.0.1] - TODO: Add release date.

  • TODO: Simplest carousel implementation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  carousel: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:carousel/carousel.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jan 21, 2018 Go to the documentation of carousel 0.1.0 Download carousel 0.1.0 archive
0.0.1 Jan 21, 2018 Go to the documentation of carousel 0.0.1 Download carousel 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
91
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use carousel.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^0.12.0