cbor 1.0.0

  • README.md
  • Installing
  • Versions
  • 25

cbor #

A CBOR library for Dart developers.

This package provides an encoding/decoding package for the Concise Binary Object Representation as documented in RFC7049.

CBOR is increasingly used as a line protocol in the IOT world where the overhead of transmitting JSON on constrained devices can be large in packet size and processing overheads.

The Cbor package provides an RFC7049 compliant solution for both the encoding and decoding of CBOR data.

The test suite supports the encoding and decoding examples in Appendix A of RFC7049 amongst others. Specifically :-

  1. Half, Single and Double precision floats are supported.
  2. Tag based encoding is supported(table 3 of the RFC).
  3. Indefinite item encoding/decoding is supported.
  4. Items can be nested to any level.
  5. All Major tag types are supported.
  6. Smallest size first is used, i.e. if an int can be encoded in one byte then this size is used, similarly a double will be encoded into its smallest precision size(unless you specify otherwise);

The implementation of maps restricts map keys to be of either string or integer type, note this is an extension to the RFC which suggests that only string keys be supported.

Please examine the files in the examples directory for usage examples and the API docs for greater detail.

In general the package guarantees to decode what it encodes and should decode all well formed CBOR data. Decoded output takes the form of standard Dart types, i.e. floats become doubles, text become String, arrays become Lists etc. This allows a simple interface for encoding from the Dart world and a simple interface to Dart world from the decoder.

Currently the package supports a payload based decoding, i.e. a complete CBOR entity needs to be submitted to the decoder. Streamed decoding may be supported in future versions. Also error handling is somewhat basic, very badly formed CBOR data may trigger exceptions in the decoding process, if you need to protect against this please enclose all decoding operations in try/catch blocks. If you use this package at both ends of your CBOR interchange nodes you will not need to do this.

Changelog #

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  cbor: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:cbor/cbor.dart';
Version Uploaded Documentation Archive
2.0.2 Aug 15, 2018 Go to the documentation of cbor 2.0.2 Download cbor 2.0.2 archive
2.0.1 Aug 15, 2018 Go to the documentation of cbor 2.0.1 Download cbor 2.0.1 archive
2.0.0 Aug 15, 2018 Go to the documentation of cbor 2.0.0 Download cbor 2.0.0 archive
1.0.4 Feb 16, 2018 Go to the documentation of cbor 1.0.4 Download cbor 1.0.4 archive
1.0.3 Dec 11, 2017 Go to the documentation of cbor 1.0.3 Download cbor 1.0.3 archive
1.0.2 Jul 14, 2017 Go to the documentation of cbor 1.0.2 Download cbor 1.0.2 archive
1.0.1 May 4, 2017 Go to the documentation of cbor 1.0.1 Download cbor 1.0.1 archive
1.0.0 Apr 11, 2017 Go to the documentation of cbor 1.0.0 Download cbor 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0