change 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new46

change

Changelog manipulation for Dart.

Changelog

Unreleased

0.0.2 - 2018-10-18

Added

  • Changelog.writeFile()

0.0.1 - 2018-10-18

Added

  • Parsing from markdown
  • Writing to markdown

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  change: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:change/change.dart';
  
Version Uploaded Documentation Archive
0.0.2 Oct 19, 2018 Go to the documentation of change 0.0.2 Download change 0.0.2 archive
0.0.1 Oct 18, 2018 Go to the documentation of change 0.0.1 Download change 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, other

Primary library: package:change/change.dart with components: io.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use change.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
markdown ^2.0.2 2.0.2
Transitive dependencies
args 1.5.1
charcode 1.1.2
Dev dependencies
test ^1.0.0