channel_mock 1.0.0

  • Installing
  • Versions
  • 20

Channel Mock

Build Status

A package to help mock plugin communication channels (MethodChannel) in Flutter.

This plugin is also available on pub

Getting Started

For help getting started with Flutter, view the online documentation. You can also visit us at Flutter Institute

For help on editing package code, view the documentation.

[0.0.2] - 2018-02-24

  • No functionality changes. This was all aesthetic.
  • Formatting all the dart code using dartfmt
  • Getting everything set up to integrate with travis-ci

[0.0.1] - 2018-02-24

  • First implementation of mock functionality

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  channel_mock: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:channel_mock/channel_mock.dart';
Version Uploaded Documentation Archive
1.0.0 Jul 5, 2018 Go to the documentation of channel_mock 1.0.0 Download channel_mock 1.0.0 archive
0.0.3 May 9, 2018 Go to the documentation of channel_mock 0.0.3 Download channel_mock 0.0.3 archive
0.0.2 Feb 24, 2018 Go to the documentation of channel_mock 0.0.2 Download channel_mock 0.0.2 archive
0.0.1 Feb 24, 2018 Go to the documentation of channel_mock 0.0.1 Download channel_mock 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0