channel_mock 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 73

Channel Mock

Build Status

A package to help mock plugin communication channels (MethodChannel) in Flutter.

This plugin is also available on pub

Getting Started

For help getting started with Flutter, view the online documentation. You can also visit us at Flutter Institute

For help on editing package code, view the documentation.

[0.0.2] - 2018-02-24

  • No functionality changes. This was all aesthetic.
  • Formatting all the dart code using dartfmt
  • Getting everything set up to integrate with travis-ci

[0.0.1] - 2018-02-24

  • First implementation of mock functionality

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  channel_mock: "^0.0.3"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:channel_mock/channel_mock.dart';
  
Version Uploaded Documentation Archive
0.0.3 May 9, 2018 Go to the documentation of channel_mock 0.0.3 Download channel_mock 0.0.3 archive
0.0.2 Feb 24, 2018 Go to the documentation of channel_mock 0.0.2 Download channel_mock 0.0.2 archive
0.0.1 Feb 24, 2018 Go to the documentation of channel_mock 0.0.1 Download channel_mock 0.0.1 archive

Analysis

We analyzed this package on May 22, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.54.0
  • pana: 0.11.1
  • Flutter: 0.4.4

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
47 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
73
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use channel_mock.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Strong-mode analysis of lib/channel_mock.dart gave the following hint:

    line: 5 col: 8
    Unused import: 'dart:ui'.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
collection ^1.14.5 1.14.6 1.14.9
flutter 0.0.0
Transitive dependencies
meta 1.1.5
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6 2.0.7
Dev dependencies
flutter_test