Character code constants.
These libraries define symbolic names for some character codes.
This is not an official Goggle package, and is not supported by Google.
Import either one of the libraries:
import "package:charcode/ascii.dart" import "package:charcode/html_entity.dart"
or import both libraries using the
The character names are preceded by a
$ to avoid conflicting with other
variables due to the short and common names (for example "$i").
The characters that are valid in a Dart identifier directly follow the
$3. Other characters are given symbolic names.
The names of letters are lower-case for lower-case letters, and mixed- or
upper-case for upper-case letters. The names of symbols are all lower-case,
and omit suffixes like "sign", "symbol" and "mark". E
ascii.dart library defines a symbolic name for each ASCII character.
For some chraceters, it has more than one name. For example the common
and the official
$ht for the horisontal tab.
html_entity.dart library defines a constant for each HTML 4.01 character
entity, using the standard entity abbreviation, incluing its case.
$aring for the lower-case
$Aring for the upper-case
The HTML entities includes all characters in the Latin-1 code page, greek letters and some mathematical symbols.
charcode.dart library just exports both
The Dart language doesn't have character literals. If that ever happens, this library will be irrelevant. Until then, this library can be used for the most common characters. See [http://dartbug.com/4415](request for character literals).
Add this to your package's pubspec.yaml file:
dependencies: charcode: ^1.0.0+1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.1.2||Jul 11, 2018|
|1.1.1||Nov 19, 2016|
|1.1.0||Sep 10, 2014|
|1.0.0+1||Sep 5, 2014|
|1.0.0||Jun 26, 2014|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.0.0 <2.0.0|