This is a DartLang port of Chart.js by Nick Downie. For more informations to Chart.js see: http://www.chartjs.org/
Add this to your package's pubspec.yaml file:
dependencies: chart: "^1.0.8"
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.8||Mar 6, 2015|
|1.0.7||Mar 2, 2015|
|1.0.6||Jan 7, 2015|
|1.0.5||Nov 11, 2014|
|1.0.4||Nov 11, 2014|
|1.0.3||Nov 6, 2014|
|1.0.2||Nov 4, 2014|
|1.0.1||Nov 4, 2014|
|1.0.0||Nov 3, 2014|
|0.3.7||Jan 28, 2014|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: web
Strong-mode analysis of
lib/src/base.dartfailed with the following error:
line: 144 col: 38
Couldn't infer type parameter 'T'.\n\nTried to infer 'dynamic' for 'T' which doesn't work:\n Type parameter 'T' declared to extend 'num'.\nThe type 'dynamic' was inferred from:\n Parameter 'a' declared as 'T'\n but argument is 'num'.\n Parameter 'b' declared as 'T'\n but argument is 'dynamic'.\n\nConsider passing explicit type argument(s) to the generic.\n\n
Changelog entries help clients to follow the progress in your code.
Fix issues reported by
dartanalyzerreported 1 error(s) and 0 warning(s).
Use constrained dependencies.
pubspec.yamlcontains 2 dependencies without version constraints. Specify version ranges for the following dependencies:
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example.
None of the files in your
example/directory matches a known example patterns. Common file name patterns include:
example.dartor you could also use