chart 1.0.8

  • README.md
  • Installing
  • Versions
  • 17

Chart.dart

This is a DartLang port of Chart.js by Nick Downie. For more informations to Chart.js see: http://www.chartjs.org/

Implemented Features

  • Chart types:
    • Line-Chart
    • Bar-Chart
    • Bool-Chart
  • Features:
    • Animations
    • config and default config
    • The possibility to add unlimited points between two labels.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  chart: ^1.0.8

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:chart/chart.dart';
  
Version Uploaded Documentation Archive
1.0.8 Mar 6, 2015 Go to the documentation of chart 1.0.8 Download chart 1.0.8 archive
1.0.7 Mar 2, 2015 Go to the documentation of chart 1.0.7 Download chart 1.0.7 archive
1.0.6 Jan 7, 2015 Go to the documentation of chart 1.0.6 Download chart 1.0.6 archive
1.0.5 Nov 11, 2014 Go to the documentation of chart 1.0.5 Download chart 1.0.5 archive
1.0.4 Nov 11, 2014 Go to the documentation of chart 1.0.4 Download chart 1.0.4 archive
1.0.3 Nov 6, 2014 Go to the documentation of chart 1.0.3 Download chart 1.0.3 archive
1.0.2 Nov 4, 2014 Go to the documentation of chart 1.0.2 Download chart 1.0.2 archive
1.0.1 Nov 4, 2014 Go to the documentation of chart 1.0.1 Download chart 1.0.1 archive
1.0.0 Nov 3, 2014 Go to the documentation of chart 1.0.0 Download chart 1.0.0 archive
0.3.7 Jan 28, 2014 Go to the documentation of chart 0.3.7 Download chart 0.3.7 archive

All 34 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
17
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because chart depends on browser any which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/chart.dart.

Run dartfmt to format lib/chart.dart.

Format lib/src/animation.dart.

Run dartfmt to format lib/src/animation.dart.

Format lib/src/bar.dart.

Run dartfmt to format lib/src/bar.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/base.dart (Run dartfmt to format lib/src/base.dart.)
  • lib/src/bool.dart (Run dartfmt to format lib/src/bool.dart.)
  • lib/src/line.dart (Run dartfmt to format lib/src/line.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use chart.dart.