chart 1.0.8

  • Installing
  • Versions
  • 47


This is a DartLang port of Chart.js by Nick Downie. For more informations to Chart.js see:

Implemented Features

  • Chart types:
    • Line-Chart
    • Bar-Chart
    • Bool-Chart
  • Features:
    • Animations
    • config and default config
    • The possibility to add unlimited points between two labels.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  chart: "^1.0.8"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:chart/chart.dart';
Version Uploaded Documentation Archive
1.0.8 Mar 6, 2015 Go to the documentation of chart 1.0.8 Download chart 1.0.8 archive
1.0.7 Mar 2, 2015 Go to the documentation of chart 1.0.7 Download chart 1.0.7 archive
1.0.6 Jan 7, 2015 Go to the documentation of chart 1.0.6 Download chart 1.0.6 archive
1.0.5 Nov 11, 2014 Go to the documentation of chart 1.0.5 Download chart 1.0.5 archive
1.0.4 Nov 11, 2014 Go to the documentation of chart 1.0.4 Download chart 1.0.4 archive
1.0.3 Nov 6, 2014 Go to the documentation of chart 1.0.3 Download chart 1.0.3 archive
1.0.2 Nov 4, 2014 Go to the documentation of chart 1.0.2 Download chart 1.0.2 archive
1.0.1 Nov 4, 2014 Go to the documentation of chart 1.0.1 Download chart 1.0.1 archive
1.0.0 Nov 3, 2014 Go to the documentation of chart 1.0.0 Download chart 1.0.0 archive
0.3.7 Jan 28, 2014 Go to the documentation of chart 0.3.7 Download chart 0.3.7 archive

All 34 versions...


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
52 / 100
Code health derived from static analysis. [more]
71 / 100
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web

Primary library: package:chart/chart.dart with components: html.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: browser, intl.

  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 errors 33 hints.

    Strong-mode analysis of lib/src/base.dart failed with the following error:

    line: 103 col: 28
    The argument type '(num) → Null' can't be assigned to the parameter type '(dynamic) → void'.

    Run dartfmt to format lib/chart.dart.

    Similar analysis of the following files failed:

    • lib/src/animation.dart (hint)
    • lib/src/bar.dart (hint)
    • lib/src/bool.dart (hint)
    • lib/src/line.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use chart.dart.


Package Constraint Resolved Available
Direct dependencies
browser any 0.10.0+3
intl any 0.15.6
Transitive dependencies
path 1.6.1