charted 0.4.3

  • README.md
  • Installing
  • Versions
  • 2

Visualization toolkit for Dart

Build Status

Charted provides

  • A selection API similar to D3.js
  • Visualization utilities ported from D3.js
  • An easy-to-use API to create charts including an SVG implementation based on the Selection API.
  • An interactive demo

Screenshot of Charted interactive demo

Screenshot of Charted interactive demo

Get started with the interactive demo

Get started with Charted by trying out the interactive demo provided with the package. Follow these instructions and get it running locally on your machine (Git and the Dart SDK has to be installed first):

git clone git@github.com:google/charted.git
cd charted
pub serve examples

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  charted: ^0.4.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:charted/charted.dart';
  
Version Uploaded Documentation Archive
0.6.1 Jul 17, 2018 Go to the documentation of charted 0.6.1 Download charted 0.6.1 archive
0.6.0 Jul 10, 2018 Go to the documentation of charted 0.6.0 Download charted 0.6.0 archive
0.5.0 Nov 16, 2017 Go to the documentation of charted 0.5.0 Download charted 0.5.0 archive
0.4.9 Nov 16, 2017 Go to the documentation of charted 0.4.9 Download charted 0.4.9 archive
0.4.8 Jul 26, 2017 Go to the documentation of charted 0.4.8 Download charted 0.4.8 archive
0.4.7 Jul 24, 2017 Go to the documentation of charted 0.4.7 Download charted 0.4.7 archive
0.4.6 May 3, 2017 Go to the documentation of charted 0.4.6 Download charted 0.4.6 archive
0.4.4 Apr 7, 2017 Go to the documentation of charted 0.4.4 Download charted 0.4.4 archive
0.4.3 Apr 6, 2017 Go to the documentation of charted 0.4.3 Download charted 0.4.3 archive
0.4.2 Apr 5, 2017 Go to the documentation of charted 0.4.2 Download charted 0.4.2 archive

All 34 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
4
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because charted depends on observable >=0.1.1 <=0.22.1+3 which requires SDK version <2.0.0 or >=2.0.0-dev.23.0 <2.0.0, version solving failed.

Health suggestions

Format lib/charts/behaviors/hovercard.dart.

Run dartfmt to format lib/charts/behaviors/hovercard.dart.

Format lib/charts/behaviors/line_marker.dart.

Run dartfmt to format lib/charts/behaviors/line_marker.dart.

Format lib/charts/cartesian_renderers/bar_chart_renderer.dart.

Run dartfmt to format lib/charts/cartesian_renderers/bar_chart_renderer.dart.

Fix additional 27 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/charts/cartesian_renderers/bubble_chart_renderer.dart (Run dartfmt to format lib/charts/cartesian_renderers/bubble_chart_renderer.dart.)
  • lib/charts/cartesian_renderers/stackedbar_chart_renderer.dart (Run dartfmt to format lib/charts/cartesian_renderers/stackedbar_chart_renderer.dart.)
  • lib/charts/chart_config.dart (Run dartfmt to format lib/charts/chart_config.dart.)
  • lib/charts/chart_data.dart (Run dartfmt to format lib/charts/chart_data.dart.)
  • lib/charts/layout_renderers/pie_chart_renderer.dart (Run dartfmt to format lib/charts/layout_renderers/pie_chart_renderer.dart.)
  • lib/charts/src/cartesian_area_impl.dart (Run dartfmt to format lib/charts/src/cartesian_area_impl.dart.)
  • lib/charts/src/chart_axis_impl.dart (Run dartfmt to format lib/charts/src/chart_axis_impl.dart.)
  • lib/charts/src/chart_data_impl.dart (Run dartfmt to format lib/charts/src/chart_data_impl.dart.)
  • lib/charts/src/chart_events_impl.dart (Run dartfmt to format lib/charts/src/chart_events_impl.dart.)
  • lib/charts/src/chart_legend_impl.dart (Run dartfmt to format lib/charts/src/chart_legend_impl.dart.)
  • lib/charts/src/chart_state_impl.dart (Run dartfmt to format lib/charts/src/chart_state_impl.dart.)
  • lib/charts/themes/quantum_theme.dart (Run dartfmt to format lib/charts/themes/quantum_theme.dart.)
  • lib/core/interpolators/interpolators.dart (Run dartfmt to format lib/core/interpolators/interpolators.dart.)
  • lib/core/scales/linear_scale.dart (Run dartfmt to format lib/core/scales/linear_scale.dart.)
  • lib/core/scales/log_scale.dart (Run dartfmt to format lib/core/scales/log_scale.dart.)
  • lib/core/scales/ordinal_scale.dart (Run dartfmt to format lib/core/scales/ordinal_scale.dart.)
  • lib/core/scales/time_scale.dart (Run dartfmt to format lib/core/scales/time_scale.dart.)
  • lib/core/time_interval.dart (Run dartfmt to format lib/core/time_interval.dart.)
  • lib/core/utils.dart (Run dartfmt to format lib/core/utils.dart.)
  • lib/core/utils/color.dart (Run dartfmt to format lib/core/utils/color.dart.)
  • lib/core/utils/rect.dart (Run dartfmt to format lib/core/utils/rect.dart.)
  • lib/layout/src/pie_layout.dart (Run dartfmt to format lib/layout/src/pie_layout.dart.)
  • lib/locale/format/number_format.dart (Run dartfmt to format lib/locale/format/number_format.dart.)
  • lib/locale/format/time_format.dart (Run dartfmt to format lib/locale/format/time_format.dart.)
  • lib/selection/selection.dart (Run dartfmt to format lib/selection/selection.dart.)
  • lib/selection/src/selection_impl.dart (Run dartfmt to format lib/selection/src/selection_impl.dart.)
  • lib/svg/shapes/rect.dart (Run dartfmt to format lib/svg/shapes/rect.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Use analysis_options.yaml. (-10 points)

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

Package is getting outdated. (-69.32 points)

The package was released 88 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use charted.dart.

The description is too long. (-10 points)

Search engines will display only the first part of the description. Try to keep it under 180 characters.