Get started with Charted by trying out the interactive demo provided with the package. Follow these instructions and get it running locally on your machine (Git and the Dart SDK has to be installed first):
git clone firstname.lastname@example.org:google/charted.git cd charted pub serve examples
Add this to your package's pubspec.yaml file:
dependencies: charted: ^0.4.6
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.6.1||Jul 17, 2018|
|0.6.0||Jul 10, 2018|
|0.5.0||Nov 16, 2017|
|0.4.9||Nov 16, 2017|
|0.4.8||Jul 26, 2017|
|0.4.7||Jul 24, 2017|
|0.4.6||May 3, 2017|
|0.4.4||Apr 7, 2017|
|0.4.3||Apr 6, 2017|
|0.4.2||Apr 5, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.