check_for_update 1.0.1

  • README.md
  • Installing
  • Versions
  • 0

check_for_update #

version 1.0.1

Generates Dart code to automatically check for a new version of the current package. Your project should depend on http. The output code is platform-independent.

One final field is generated: PACKAGE_VERSION - The package's active version. Two methods are generated:

  • fetchCurrentVersion: Asks the Pub API what the latest version of the package is.
  • checkForUpdate: Compares PACKAGE_VERSION to the result of fetchCurrentVersion and returns null if no update is available. Otherwise, the new version will be returned.

Usage #

Generate from the project pubspec.yaml:

import 'package:build_runner/build_runner.dart';
import 'package:check_for_update/builder.dart';

final PhaseGroup phaseGroup = new PhaseGroup.singleAction(
    new CheckForUpdateBuilder(),
    new InputSet('example', const ['pubspec.yaml']));

You can add the output to a subdirectory, i.e. lib:

new CheckForUpdateBuilder(subDirectory: 'lib')

Overrides #

Specifying a specific package name to scan for updates:

new CheckForUpdateBuilder(packageName: 'shelf')

Specifying a custom Pub API URL:

new CheckForUpdateBuilder(pubApiRoot: 'https://foo.bar/pub-api')

Specifying a specific version to check against:

new CheckForUpdateBuilder(currentVersion: new Version(1, 2, 0, pre: 'alpha.6'))

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  check_for_update: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:check_for_update/check_for_update.dart';
  
Version Uploaded Documentation Archive
1.0.1 Mar 24, 2017 Go to the documentation of check_for_update 1.0.1 Download check_for_update 1.0.1 archive
1.0.0 Mar 24, 2017 Go to the documentation of check_for_update 1.0.0 Download check_for_update 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0