Add this to your package's pubspec.yaml file:
dependencies: chess3man_engine: ^0.0.7
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:chess3man_engine/asaomgen.dart'; import 'package:chess3man_engine/vftpgen.dart'; import 'package:chess3man_engine/afterboard.dart'; import 'package:chess3man_engine/amft.dart'; import 'package:chess3man_engine/board.dart'; import 'package:chess3man_engine/castling.dart'; import 'package:chess3man_engine/castlingcheck.dart'; import 'package:chess3man_engine/colors.dart'; import 'package:chess3man_engine/epstore.dart'; import 'package:chess3man_engine/moats.dart'; import 'package:chess3man_engine/move.dart'; import 'package:chess3man_engine/pos.dart'; import 'package:chess3man_engine/possib.dart'; import 'package:chess3man_engine/prom.dart'; import 'package:chess3man_engine/state.dart'; import 'package:chess3man_engine/threat.dart';
|0.0.7||Nov 11, 2016|
|0.0.6||Nov 1, 2016|
|0.0.5||Oct 31, 2016|
|0.0.4||Oct 30, 2016|
|0.0.3||Oct 29, 2016|
|0.0.2||Oct 29, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.8.0 <2.0.0|