circle_wave_progress 0.0.4

  • Example
  • Installing
  • Versions
  • new44

Circle Wave Progress

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.



Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  circle_wave_progress: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:circle_wave_progress/circle_wave_progress.dart';
Version Uploaded Documentation Archive
0.0.4 Jan 10, 2019 Go to the documentation of circle_wave_progress 0.0.4 Download circle_wave_progress 0.0.4 archive
0.0.3 Jan 10, 2019 Go to the documentation of circle_wave_progress 0.0.3 Download circle_wave_progress 0.0.3 archive
0.0.2 Jan 10, 2019 Go to the documentation of circle_wave_progress 0.0.2 Download circle_wave_progress 0.0.2 archive
0.0.1 Jan 9, 2019 Go to the documentation of circle_wave_progress 0.0.1 Download circle_wave_progress 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/circle_wave_progress.dart.

Run flutter format to format lib/circle_wave_progress.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies