circular_progress_gauge_odo 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 38

circular_progress_gauge_odo #

Introducing the new "odo" widget in flutter. It simulates a odometer or a speedometer style gauge in mobile application.

Getting Started #

all you need to do is include below code: Odo( inputValue: _value ),

Here, _value will come as input which can have a range from 0 to 1.0. To display custom range on Odo, give values to rangeMinValue and rangeMaxValue parameters.

Odo widget attributes and sample values. #

size = 300.0,
minRangeColor = Colors.green,
midRangeColor = Colors.amberAccent,
maxRangeColor = Colors.red,
bottomCircleColor = Colors.black,
innerCircleColor = Colors.white,
displayBackgroundColor= Colors.blueGrey,
indicatorColor = Colors.black,
displayColor = Colors.white70 ,
displayBorderColor = Colors.black,
inputValue = _value,
rangeMinValue = 0.0,
rangeMaxValue = 100.0

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1 #

  • Introducing the new "odo" widget in flutter.[Release 0.0.1] It simulates a odometer or a speedometer type gauge in mobile application.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:circular_progress_gauge_odo/odo.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Odo Demo',
      debugShowCheckedModeBanner: false,
      home: new MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => new _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  double _value = 0.0;

  @override
  Widget build(BuildContext context) {
    return new Scaffold(
      body: Center(
          child: Column(
        mainAxisAlignment: MainAxisAlignment.spaceEvenly,
        children: <Widget>[
          Odo(
            size: 300.0,
            inputValue: _value,
            rangeMinValue: 0.0,
            rangeMaxValue: 100.0,
          ),
          Slider(
              value: _value,
              min: 0.0,
              max: 1.0,
              onChanged: (sliderInput) {
                setState(() {
                  _value = sliderInput;
                });
              })
        ],
      )),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  circular_progress_gauge_odo: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:circular_progress_gauge_odo/circular_progress_gauge_odo.dart';
  
Version Uploaded Documentation Archive
1.0.0 Sep 8, 2018 Go to the documentation of circular_progress_gauge_odo 1.0.0 Download circular_progress_gauge_odo 1.0.0 archive
0.0.1 Sep 7, 2018 Go to the documentation of circular_progress_gauge_odo 0.0.1 Download circular_progress_gauge_odo 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
76
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <7.0.0