cli_menu 0.1.0

  • Example
  • Installing
  • Versions
  • new50


Screencast of cli_menu in action

A library for adding simple menus to console (CLI) apps. It will print a list of options and then let user choose via keyboard up and down arrows (when ANSI is available), or via a prompt for a number.

This library is conservative – it prefers compatibility over fancy ANSI features and unicode glyphs.

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand


import 'package:cli_menu/cli_menu.dart';

void main() {
  print("Pick favorite color:");
  final menu = new Menu(["Red", "Green", "Orange", "Fuchsia"]);
  final result = menu.choose();
  print("You picked: $result");

1. Depend on it

Add this to your package's pubspec.yaml file:

  cli_menu: "^0.1.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:cli_menu/cli_menu.dart';
Version Uploaded Documentation Archive
0.1.0 Feb 7, 2018 Go to the documentation of cli_menu 0.1.0 Download cli_menu 0.1.0 archive
0.0.1 Feb 6, 2018 Go to the documentation of cli_menu 0.0.1 Download cli_menu 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 7, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
99 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, other

Primary library: package:cli_menu/cli_menu.dart with components: io.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
cli_util ^0.1.2+1 0.1.2+1
Transitive dependencies
path 1.5.1