client 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 21

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:client/client.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  client: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:client/client.dart';
  
Version Uploaded Documentation Archive
0.0.2 Feb 15, 2019 Go to the documentation of client 0.0.2 Download client 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
38
Overall:
Weighted score of the above. [more]
21
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: Because client depends on utils ^0.0.11 which doesn't match any versions, version solving failed.

Health suggestions

Format lib/client.dart.

Run dartfmt to format lib/client.dart.

Format lib/src/decoding/bulletinDefinition/BulletinDefinition.dart.

Run dartfmt to format lib/src/decoding/bulletinDefinition/BulletinDefinition.dart.

Format lib/src/decoding/bulletinDefinition/PossibleAnswer.dart.

Run dartfmt to format lib/src/decoding/bulletinDefinition/PossibleAnswer.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/decoding/bulletinDefinition/Question.dart (Run dartfmt to format lib/src/decoding/bulletinDefinition/Question.dart.)
  • lib/src/decoding/bulletinDefinition/Questionnaire.dart (Run dartfmt to format lib/src/decoding/bulletinDefinition/Questionnaire.dart.)
  • lib/src/restApi.dart (Run dartfmt to format lib/src/restApi.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and client.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0