clock 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 81

This package provides a Clock class which encapsulates the notion of the "current time" and provides easy access to points relative to the current time. Different Clocks can have a different notion of the current time, and the default top-level clock's notion can be swapped out to reliably test timing-dependent code.

For example, you can use clock in your libraries like this:

// run_with_timing.dart
import 'package:clock/clock.dart';

/// Runs [callback] and prints how long it took.
T runWithTiming<T>(T callback()) {
  var stopwatch = clock.stopwatch()..start();
  var result = callback();
  print("It took ${stopwatch.elapsed}!");
  return result;
}

...and then test your code using the fake_async package, which automatically overrides the current clock:

// run_with_timing_test.dart
import 'run_with_timing.dart';

import 'package:fake_async/fake_async.dart';
import 'package:test/test.dart';

void main() {
  test("runWithTiming() prints the elapsed time", () {
    new FakeAsync().run((async) {
      expect(() {
        runWithTiming(() {
          async.elapse(new Duration(seconds: 10));
        });
      }, prints("It took 0:00:10.000000!"));
    });
  });
}

1.0.1

  • Update to lowercase Dart core library constants.

1.0.0

This release contains the Clock class that was defined in quiver. It's backwards-compatible with the quiver version, and mostly backwards-compatible with the old version of the clock package.

New Features

  • A top-level clock field has been added that provides a default Clock implementation. It can be controlled by the withClock() function. It should generally be used in preference to manual dependency-injection, since it will work with the fake_async package.

  • A Clock.stopwatch() method has been added that creates a Stopwatch that uses the clock as its source of time.

Changes Relative to clock 0.1

  • The top-level new getter and getStopwatch() methods are deprecated. clock.new() and clock.stopwatch() should be used instead.

  • Clock.getStopwatch() is deprecated. Clock.stopwatch() should be used instead.

  • The isFinal argument to withClock() is deprecated.

  • new Clock() now takes an optional positional argument that returns the current time as a DateTime instead of its old arguments.

  • Clock.now() is now a method rather than a getter.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  clock: "^1.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:clock/clock.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jul 14, 2018 Go to the documentation of clock 1.0.1 Download clock 1.0.1 archive
1.0.0 May 1, 2018 Go to the documentation of clock 1.0.0 Download clock 1.0.0 archive
0.1.2 Oct 7, 2014 Go to the documentation of clock 0.1.2 Download clock 0.1.2 archive
0.1.1 Oct 7, 2014 Go to the documentation of clock 0.1.1 Download clock 0.1.1 archive
0.1.0 Oct 7, 2014 Go to the documentation of clock 0.1.0 Download clock 0.1.0 archive
0.0.1 Oct 6, 2014 Go to the documentation of clock 0.0.1 Download clock 0.0.1 archive

Analysis

We analyzed this package on Jul 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
63 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
81
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:clock/clock.dart.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use clock.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/src/clock.dart gave the following hint:

    line: 37 col: 41
    'systemTime' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/default.dart gave the following hint:

    line: 38 col: 9
    'isFinal' is deprecated and shouldn't be used.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.36.0 <3.0.0
meta >=0.9.0 <2.0.0 1.1.5
Dev dependencies
test ^0.12.28