cmustify 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 30

cmustify

What is cmustify? This is a cmus notifier that shows the current song into notifications.

This is a rewrite in Dart for fun of https://github.com/kimond/cmustify

Install

Install the executable using:

$ pub global activate cmustify

Contributions

Contributions are welcome.

v0.0.2

  • Fix args parsing

v0.0.1

  • First release

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate cmustify

2. Use it

The package has the following executables:


$ cmustify

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cmustify: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cmustify/cmustify.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jul 27, 2016 Go to the documentation of cmustify 0.0.2 Download cmustify 0.0.2 archive
0.0.1 Jul 27, 2016 Go to the documentation of cmustify 0.0.1 Download cmustify 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because cmustify depends on test >=0.12.0-beta.3 <1.3.0 which requires SDK version >=1.8.0 <2.0.0-∞, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is too old.

The package was released more than two years ago.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use cmustify.dart.

Use analysis_options.yaml.

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.