color_rgb_a 0.0.1+1

  • Installing
  • Versions
  • 55


Represents a color in the red-green-blue scheme with an optional alpha component. Designed for use with both Flutter and CSS.


This class has been incorporated into the shared_theme package. Specifically, here.

[0.0.1+1] - October 1, 2018

[0.0.1] - August 25, 2018

  • First release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  color_rgb_a: ^0.0.1+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:color_rgb_a/color_rgb_a.dart';
Version Uploaded Documentation Archive
0.0.1+1 Oct 2, 2018 Go to the documentation of color_rgb_a 0.0.1+1 Download color_rgb_a 0.0.1+1 archive
0.0.1 Aug 25, 2018 Go to the documentation of color_rgb_a 0.0.1 Download color_rgb_a 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 26, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.5


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:color_rgb_a/color_rgb_a.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use color_rgb_a.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
Dev dependencies
test ^1.3.0