compiled_mustache 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

compiled_mustache

Travis Pub

This is a lightweight mustache renderer for Dart. It is 2-15x faster than mustache4dart, and provides the ability to cache parsed templates to avoid having to read from disk and parse files on every render.

Changelog

1.0.1

  • Switch to automatic deployment

1.0.0

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  compiled_mustache: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:compiled_mustache/compiled_mustache.dart';
  
Version Uploaded Documentation Archive
1.0.2 Dec 2, 2017 Go to the documentation of compiled_mustache 1.0.2 Download compiled_mustache 1.0.2 archive
1.0.1 Nov 29, 2017 Go to the documentation of compiled_mustache 1.0.1 Download compiled_mustache 1.0.1 archive
1.0.0 Nov 29, 2017 Go to the documentation of compiled_mustache 1.0.0 Download compiled_mustache 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Fix lib/src/context.dart. (-25 points)

Analysis of lib/src/context.dart failed with 1 error:

line 40 col 20: The operator '[]' isn't defined for the class 'Object'.

Fix lib/compiled_mustache.dart. (-0.50 points)

Analysis of lib/compiled_mustache.dart reported 1 hint:

line 5 col 8: Unused import: 'dart:io'.

Fix lib/src/node.dart. (-0.50 points)

Analysis of lib/src/node.dart reported 1 hint:

line 12 col 8: The value of the field '_recursivePartal' isn't used.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/compiled_template.dart (Run dartfmt to format lib/src/compiled_template.dart.)
  • lib/src/compiler.dart (Run dartfmt to format lib/src/compiler.dart.)
  • lib/src/delimiter.dart (Run dartfmt to format lib/src/delimiter.dart.)
  • lib/src/parser.dart (Run dartfmt to format lib/src/parser.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is getting outdated. (-0.82 points)

The package was released 52 weeks ago.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use compiled_mustache.dart. Packages with multiple examples should use example/readme.md.

Dependencies

Package Constraint Resolved Available
Dev dependencies
benchmark_harness >=1.0.0 <2.0.0
grinder ^0.8.0
mustache4dart ^2.1.0
path ^1.5.0
test ^0.12.27
yaml ^2.1.13