compiler_tools 1.0.0-dev

  • README.md
  • Installing
  • Versions
  • 30

compiler_tools

Helper library for language tooling with Dart.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  compiler_tools: ^1.0.0-dev

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:compiler_tools/compiler_tools.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev Dec 18, 2016 Go to the documentation of compiler_tools 1.0.0-dev Download compiler_tools 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:compiler_tools/compiler_tools.dart.

Health suggestions

Fix lib/src/location.dart. (-0.50 points)

Analysis of lib/src/location.dart reported 1 hint:

line 26 col 17: Always override hashCode if overriding ==.

Format lib/compiler_tools.dart.

Run dartfmt to format lib/compiler_tools.dart.

Format lib/src/token.dart.

Run dartfmt to format lib/src/token.dart.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-96.16 points)

The package was released 102 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use compiler_tools.dart.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
charcode ^1.1.1 1.1.2
source_maps ^0.10.2 0.10.8
source_span ^1.3.0 1.4.1
string_scanner ^1.0.1 1.0.4
Transitive dependencies
meta 1.1.6
path 1.6.2