compiler_unsupported 1.22.0

  • readme.md
  • changelog.md
  • Installing
  • Versions
  • 0

compiler_unsupported

An unsupported copy of the dart2js compiler.

Build Status pub package

About

This is a copy of the dart2js source available as a package. The API of this package can and will change in unpredictable and incompatible ways.

Changelog

1.22.0 (2017-02-14)

  • upgraded to SDK 1.22.0

1.21.0 (2016-12-09)

  • upgraded to SDK 1.21.0

1.20.0 (2016-11-18)

  • upgraded to SDK 1.20.0

1.19.0 (2016-09-21)

  • upgraded to SDK 1.19.0

1.18.0 (2016-09-21)

  • upgraded to SDK 1.18.0

1.17.0 (2016-09-21)

  • upgraded to SDK 1.17.0

1.16.0-dev.5.0 (2016-04-16)

  • upgraded to SDK 1.16.0-dev.5.0

1.15.0 (2016-03-21)

  • upgraded to SDK 1.15.0

1.14.2 (2016-03-21)

  • upgraded to SDK 1.14.2

1.14.1 (2016-03-21)

  • upgraded to SDK 1.14.1

1.14.0 (2016-03-21)

  • upgraded to SDK 1.14.0

1.13.2 (2016-03-21)

  • upgraded to SDK 1.13.2

1.13.1 (2016-01-01)

  • upgraded to SDK 1.13.1

1.13.0 (2015-11-23)

  • upgraded to SDK 1.13.0

1.13.0-dev.7.9 (2015-11-04)

  • upgraded to SDK 1.13.0-dev.7.9

1.13.0-dev.7.6 (2015-11-03)

  • upgraded to SDK 1.13.0-dev.7.6

1.13.0-dev.7.0 (2015-10-14)

  • upgraded to SDK 1.13.0-dev.7.0

1.13.0-dev.6.0 (2015-10-14)

  • upgraded to SDK 1.13.0-dev.6.0

1.12.1 (2015-09-14)

  • upgraded to SDK 1.12.1

1.12.0-dev.5.2 (2015-08-11)

  • upgraded to SDK 1.12.0-dev.5.2

1.11.1 (2015-07-08)

  • upgraded to SDK 1.11.1

1.11.0-dev.5.7 (2015-06-24)

  • upgraded to SDK 1.11.0-dev.5.7

1.11.0-dev.5.4 (2015-06-18)

  • upgraded to SDK 1.11.0-dev.5.4

1.10.1 (2015-05-14)

  • upgraded to SDK 1.10.1

1.10.0 (2015-05-01)

  • upgraded to SDK 1.10.0

1.9.3 (2015-04-13)

  • upgraded to SDK 1.9.3

1.9.2 (2015-04-09)

  • upgraded to SDK 1.9.2

1.9.0-dev.10.4 (2015-03-09)

  • upgraded to SDK 1.9.0-dev.10.4

1.9.0-dev.3.0 (2015-01-08)

  • upgraded to SDK 1.9.0-dev.3.0

1.9.0-dev.2.2.1 (2014-12-29)

  • added the SDK sources to the package and added the sdk_io.dart library

1.9.0-dev.2.2 (2014-12-24)

  • upgraded to SDK 1.9.0-dev.2.2

0.7.3

  • upgraded to SDK 1.9.0

0.7.2

  • upgraded to SDK 1.6.0

0.7.1

  • upgraded to SDK 1.3.0-dev.3.2.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  compiler_unsupported: ^1.22.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:compiler_unsupported/compiler.dart';
import 'package:compiler_unsupported/compiler_new.dart';
import 'package:compiler_unsupported/libraries.dart';
import 'package:compiler_unsupported/sdk.dart';
import 'package:compiler_unsupported/sdk_io.dart';
import 'package:compiler_unsupported/version.dart';
  
Version Uploaded Documentation Archive
1.22.0 Feb 14, 2017 Go to the documentation of compiler_unsupported 1.22.0 Download compiler_unsupported 1.22.0 archive
1.21.0 Dec 9, 2016 Go to the documentation of compiler_unsupported 1.21.0 Download compiler_unsupported 1.21.0 archive
1.20.0 Nov 18, 2016 Go to the documentation of compiler_unsupported 1.20.0 Download compiler_unsupported 1.20.0 archive
1.19.0 Sep 22, 2016 Go to the documentation of compiler_unsupported 1.19.0 Download compiler_unsupported 1.19.0 archive
1.18.0 Sep 21, 2016 Go to the documentation of compiler_unsupported 1.18.0 Download compiler_unsupported 1.18.0 archive
1.17.0 Sep 21, 2016 Go to the documentation of compiler_unsupported 1.17.0 Download compiler_unsupported 1.17.0 archive
1.16.0 Apr 26, 2016 Go to the documentation of compiler_unsupported 1.16.0 Download compiler_unsupported 1.16.0 archive
1.15.0 Mar 22, 2016 Go to the documentation of compiler_unsupported 1.15.0 Download compiler_unsupported 1.15.0 archive
1.13.1 Jan 1, 2016 Go to the documentation of compiler_unsupported 1.13.1 Download compiler_unsupported 1.13.1 archive
1.13.0 Nov 23, 2015 Go to the documentation of compiler_unsupported 1.13.0 Download compiler_unsupported 1.13.0 archive

All 70 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

This package is not analyzed, because it is discontinued.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.11.0 <2.0.0