An unsupported copy of the dart2js compiler.
This is a copy of the dart2js source available as a package. The API of this package can and will change in unpredictable and incompatible ways.
Add this to your package's pubspec.yaml file:
dependencies: compiler_unsupported: ^1.22.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:compiler_unsupported/compiler.dart'; import 'package:compiler_unsupported/compiler_new.dart'; import 'package:compiler_unsupported/libraries.dart'; import 'package:compiler_unsupported/sdk.dart'; import 'package:compiler_unsupported/sdk_io.dart'; import 'package:compiler_unsupported/version.dart';
|1.22.0||Feb 14, 2017|
|1.21.0||Dec 9, 2016|
|1.20.0||Nov 18, 2016|
|1.19.0||Sep 22, 2016|
|1.18.0||Sep 21, 2016|
|1.17.0||Sep 21, 2016|
|1.16.0||Apr 26, 2016|
|1.15.0||Mar 22, 2016|
|1.13.1||Jan 1, 2016|
|1.13.0||Nov 23, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
This package is not analyzed, because it is discontinued.
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.11.0 <2.0.0|