config 0.0.5

  • Example
  • Installing
  • Versions
  • 3


Support for environment configurations


A simple usage example:

import 'package:config/config.dart';

main() {
  // TODO: ...

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Update dependency versions on constrain and converters


  • Initial version, created by Stagehand


// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library config.example;

//import 'package:config/config.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  config: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:config/config.dart';
Version Uploaded Documentation Archive
0.0.5 Apr 10, 2016 Go to the documentation of config 0.0.5 Download config 0.0.5 archive
0.0.4 Jan 6, 2016 Go to the documentation of config 0.0.4 Download config 0.0.4 archive
0.0.3 Aug 13, 2015 Go to the documentation of config 0.0.3 Download config 0.0.3 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0