config 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 22

config

Support for environment configurations

Usage

A simple usage example:

import 'package:config/config.dart';

main() {
  // TODO: ...
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.4

  • Update dependency versions on constrain and converters

0.0.1

  • Initial version, created by Stagehand

example/config.dart

// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library config.example;

//import 'package:config/config.dart';

main() {}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  config: "^0.0.5"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:config/config.dart';
        
Version Uploaded Documentation Archive
0.0.5 Apr 10, 2016 Go to the documentation of config 0.0.5 Download config 0.0.5 archive
0.0.4 Jan 6, 2016 Go to the documentation of config 0.0.4 Download config 0.0.4 archive
0.0.3 Aug 13, 2015 Go to the documentation of config 0.0.3 Download config 0.0.3 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
7 / 100
Health:
Code health derived from static analysis. [more]
55 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
13 / 100
Overall score:
Weighted score of the above. [more]
22

Platforms

Detected platforms: other

Primary library: package:config/config.dart with components: io, mirrors.

Suggestions

  • Fix lib/src/config.dart.

    Strong-mode analysis of lib/src/config.dart failed with the following error:

    line: 8 col: 33
    Type parameter bound types must be instantiated.

  • Fix lib/src/config_impl.dart.

    Strong-mode analysis of lib/src/config_impl.dart failed with the following error:

    line: 9 col: 40
    Type parameter bound types must be instantiated.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 2 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0
constrain ^0.2.8 0.2.8
converters ^0.0.3 0.0.3
logging >=0.10.0 <0.12.0 0.11.3+1
option ^1.1.0 1.2.0
quiver >=0.18.2 <0.22.0 0.21.4 0.28.0
Transitive dependencies
collection 1.14.5
concepts 0.2.0
either 0.1.8
matcher 0.12.1+4
path 1.5.1
stack_trace 1.9.2
Dev dependencies
test >=0.12.0 <0.13.0