configer 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

Configer

Configer is a small library for Dart that makes creating config files easy.

Early alpha state of development! But it works :D

Inspired by Yamler of geNAZt (https://www.spigotmc.org/resources/yamler.315/)

Usage

A simple usage example:

import 'dart:io';
import 'package:Configer/configer.dart';

main( ) async {
    var myConfig = new TestConfig( new File( "myCoolConf.json" ) );
    await myConfig.init();
    print( myConfig.foo ); // Outputs the value in
    print( myConfig.bar ); // myCoolConf.json or the
    print( myConfig.foobar ); // default value if there is one
}

class TestConfig extends Config {
    int foo = 34;
    bool bar;
    String foobar;

    TestConfig( File configLocation ) : super( configLocation );
}

This generates a file myCoolConf.json which contains the default values:

{
  "foo": 34,
  "bar": null,
  "foobar": "Default string"
}

Just edit the config and see the result!

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version
  • basic functionality
  • save/read config file
  • default values

example/configer_example.dart

// Copyright (c) 2016, Moritz Beck (Birkenstab). All rights reserved. Use of this source code

// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:io';

import 'package:configer/configer.dart';

main( ) async {
    var myConfig = new TestConfig( new File( "myConf.json" ) );
    await myConfig.init();
    print( myConfig );
}

class TestConfig extends Config {
    String myString;
    int foo = 34;
    bool bar;
    String foobar;
    bool barfoo;
    var thisIsADynamicField;

    TestConfig( File configLocation ) : super( configLocation );

    @override
    String toString( ) {
        return 'TestConfig{myString: $myString, foo: $foo, bar: $bar, foobar: $foobar, barfoo: $barfoo, thisIsADynamicField: $thisIsADynamicField}';
    }
    
    
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  configer: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:configer/configer.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 8, 2016 Go to the documentation of configer 0.0.1 Download configer 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0