console_log_handler 0.5.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 32

console_log_handler

Shows your log-messages on the Console (Browser + Commandline)

Screenshot Screenshot

How to use it

library unit.test;

import 'package:logging/logging.dart';

// Browser
import "package:console_log_handler/console_log_handler.dart";

// Commandline
import "package:console_log_handler/print_log_handler.dart";

void main() {
    configLogging();
    final Logger _logger = new Logger("test");

    try {
        throw "Sample for exception";
    } on String catch( error, stacktrace) {

        _logger.severe("Caught error",error,stacktrace);
    }

}

If you have problems

License

Copyright 2017 Michael Mitterer (office@mikemitterer.at), 
IT-Consulting and Development Limited, Austrian Branch

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, 
software distributed under the License is distributed on an 
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, 
either express or implied. See the License for the specific language 
governing permissions and limitations under the License.

If this plugin is helpful for you - please (Circle) me.

Change Log for console_log_handler

Console logger

v0.5 - 2017-12-07

Feature

  • Removed 'logging'-import. Not necessary anymore 17ac126
  • Browser-Console andgit tag v0.4! Terminal-Console is supported b1fc60e

v0.3 - 2017-12-06

Feature

  • Remove logging_handlers-dependency, intl-dependency is more relaxed now 70b074d

Docs

  • Changed documentation in README 9ef9d39

v0.2.3 - 2016-11-16

Docs

v0.2.2 - 2016-11-16

Docs

v0.2.1 - 2015-12-03

Docs

  • Moved to 'tests' instead of 'unittest', Grinder added 7afa41e

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  console_log_handler: ^0.5.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:console_log_handler/console_log_handler.dart';
  
Version Uploaded Documentation Archive
1.1.3 Aug 21, 2018 Go to the documentation of console_log_handler 1.1.3 Download console_log_handler 1.1.3 archive
1.1.0 Aug 14, 2018 Go to the documentation of console_log_handler 1.1.0 Download console_log_handler 1.1.0 archive
1.0.8 Jun 28, 2018 Go to the documentation of console_log_handler 1.0.8 Download console_log_handler 1.0.8 archive
1.0.3 May 30, 2018 Go to the documentation of console_log_handler 1.0.3 Download console_log_handler 1.0.3 archive
0.5.7 Dec 11, 2017 Go to the documentation of console_log_handler 0.5.7 Download console_log_handler 0.5.7 archive
0.5.4 Dec 7, 2017 Go to the documentation of console_log_handler 0.5.4 Download console_log_handler 0.5.4 archive
0.5.0 Dec 7, 2017 Go to the documentation of console_log_handler 0.5.0 Download console_log_handler 0.5.0 archive
0.4.1 Dec 6, 2017 Go to the documentation of console_log_handler 0.4.1 Download console_log_handler 0.4.1 archive
0.3.1 Dec 6, 2017 Go to the documentation of console_log_handler 0.3.1 Download console_log_handler 0.3.1 archive
0.3.0 Dec 6, 2017 Go to the documentation of console_log_handler 0.3.0 Download console_log_handler 0.3.0 archive

All 18 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0