contacts_service 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 96

contacts_service #

pub package Build Status Coverage Status

A Flutter plugin to access and manage the device's contacts.

Usage #

To use this plugin, add contacts_service as a dependency in your pubspec.yaml file.

Make sure you add the following permissions to your Android Manifest:

<uses-permission android:name="android.permission.READ_CONTACTS" />
<uses-permission android:name="android.permission.WRITE_CONTACTS" />

On iOS, make sure to set NSContactsUsageDescription in the Info.plist file

<key>NSContactsUsageDescription</key>
<string>This app requires contacts access to function properly.</string>

To check and request user permission to access contacts, I recommend using the following plugin: flutter_simple_permissions

If you do not request user permission or have it granted, the application will fail. For testing purposes, you can manually set the permissions for your test app in Settings for your app on the device that you are using. For Android, go to "Settings" - "Apps" - select your test app - "Permissions" - then turn "on" the slider for contacts.

Example #

// Import package
import 'package:contacts_service/contacts_service.dart';

// Get all contacts
Iterable<Contact> contacts = await ContactsService.getContacts();

// Get contacts matching a string
Iterable<Contact> johns = await ContactsService.getContacts(query : "john");

// Add a contact
// The contact must have a firstName / lastName to be successfully addded
await ContactsService.addContact(newContact);

//Delete a contact
await ContactsService.deleteContact(contact);

Example

Todo #

  • [ ] update contact

Contributions #

Contributions are welcome! If you find a bug or want a feature, please fill an issue.

If you want to contribute code please create a pull request.

Credits #

Heavily inspired from rt2zz's react native plugin

[0.1.1] - January 11th, 2019

  • Added Ability to Share VCF Card (@AppleEducate)

[0.1.0] - January 4th, 2019

  • Update pubspec version and maintainer info for Dart Pub
  • Add withThumbnails and update example (@trinqk)

[0.0.9] - October 10th, 2018

  • Fix an issue when fetching contacts on Android

[0.0.8] - August 16th, 2018

  • Fix an issue with phones being added to emails on Android
  • Update plugin for dart 2

[0.0.7] - July 10th, 2018

  • Fix PlatformException on iOS
  • Add a refresh to the contacts list in the sample app when you add a contact
  • Return more meaningful errors when addContact() fails on iOS
  • Code tidy up

[0.0.6] - April 13th, 2018

  • Add contact thumbnails

[0.0.5] - April 5th, 2018

  • Fix with dart2 compatibility

[0.0.4] - February 1st, 2018

  • Implement deleteContact(Contact c) for Android and iOS

[0.0.3] - January 31st, 2018

  • Implement addContact(Contact c) for Android and iOS

[0.0.2] - January 30th, 2018

  • Now retrieving contacts' prefixes and suffixes

[0.0.1] - January 30th, 2018

  • All contacts can be retrieved
  • Contacts matching a string can be retrieved

example/README.md

contacts_service_example #

Demonstrates how to use the contacts_service plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  contacts_service: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:contacts_service/contacts_service.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jan 31, 2019 Go to the documentation of contacts_service 0.1.1 Download contacts_service 0.1.1 archive
0.1.0 Jan 11, 2019 Go to the documentation of contacts_service 0.1.0 Download contacts_service 0.1.0 archive
0.0.9 Oct 10, 2018 Go to the documentation of contacts_service 0.0.9 Download contacts_service 0.0.9 archive
0.0.8 Aug 16, 2018 Go to the documentation of contacts_service 0.0.8 Download contacts_service 0.0.8 archive
0.0.7 Jul 10, 2018 Go to the documentation of contacts_service 0.0.7 Download contacts_service 0.0.7 archive
0.0.6 Apr 13, 2018 Go to the documentation of contacts_service 0.0.6 Download contacts_service 0.0.6 archive
0.0.5 Apr 5, 2018 Go to the documentation of contacts_service 0.0.5 Download contacts_service 0.0.5 archive
0.0.4 Feb 1, 2018 Go to the documentation of contacts_service 0.0.4 Download contacts_service 0.0.4 archive
0.0.3 Jan 31, 2018 Go to the documentation of contacts_service 0.0.3 Download contacts_service 0.0.3 archive
0.0.2 Jan 30, 2018 Go to the documentation of contacts_service 0.0.2 Download contacts_service 0.0.2 archive

All 11 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
96
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/share.dart. (-2.48 points)

Analysis of lib/share.dart reported 5 hints:

line 26 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 31 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 36 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 48 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 54 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Format lib/contacts_service.dart.

Run flutter format to format lib/contacts_service.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.58.0.flutter-f981f09760 <3.0.0
flutter 0.0.0
path_provider ^0.4.1 0.4.1 0.5.0+1
share_extend ^1.0.3 1.0.3
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
test ^1.3.0