convert 2.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 83

Conversion utilities package

This package contains encoders and decoders for converting between different data representations. It's the external counterpart of the dart:convert core library, and contains less-central APIs and APIs that need more flexible versioning.

2.0.1

  • PercentEncoder no longer encodes digits. This follows the specified behavior.

2.0.0

Note: No new APIs have been added in 2.0.0. Packages that would use 2.0.0 as a lower bound should use 1.0.0 instead—for example, convert: ">=1.0.0 <3.0.0".

  • HexDecoder, HexEncoder, PercentDecoder, and PercentEncoder no longer extend ChunkedConverter.

1.1.1

  • Fix all strong-mode warnings.

1.1.0

  • Add AccumulatorSink, ByteAccumulatorSink, and StringAccumulatorSink classes for providing synchronous access to the output of chunked converters.

1.0.1

  • Small improvement in percent decoder efficiency.

1.0.0

  • Initial version

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  convert: "^2.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:convert/convert.dart';
        
Version Uploaded Documentation Archive
2.0.1 Aug 8, 2016 Go to the documentation of convert 2.0.1 Download convert 2.0.1 archive
2.0.0 Jun 3, 2016 Go to the documentation of convert 2.0.0 Download convert 2.0.0 archive
1.1.1 Apr 27, 2016 Go to the documentation of convert 1.1.1 Download convert 1.1.1 archive
1.1.0 Apr 22, 2016 Go to the documentation of convert 1.1.0 Download convert 1.1.0 archive
1.0.1 Nov 3, 2015 Go to the documentation of convert 1.0.1 Download convert 1.0.1 archive
1.0.0 Oct 8, 2015 Go to the documentation of convert 1.0.0 Download convert 1.0.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
96 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
29 / 100
Overall score:
Weighted score of the above. [more]
83
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:convert/convert.dart.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use convert.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 hints.

    Run dartfmt to format lib/src/hex/decoder.dart.

    Run dartfmt to format lib/src/hex/encoder.dart.

    Similar analysis of the following files failed:

    • lib/src/percent/decoder.dart (hint)
    • lib/src/percent/encoder.dart (hint)
    • lib/src/utils.dart (hint)
  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.0-dev.6.2 <2.0.0
charcode ^1.1.0 1.1.1
typed_data ^1.1.0 1.1.5
Dev dependencies
test ^0.12.0