convert_to_wui 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new50

Convert html files to wui_builder components

pub global activate convert_to_wui

pub global run convert_to_wui <path to html file>

Example:

<div class='foo'>hi</div>

converts to

VNode generatedElement1() => new Vdiv()
    ..className = 'foo'
    ..text = 'hi';

0.0.1

A start

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  convert_to_wui: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.1 Jan 29, 2018 Go to the documentation of convert_to_wui 0.0.1 Download convert_to_wui 0.0.1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
50

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use convert_to_wui.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
dart_style >=0.2.4 <2.0.0 1.0.9+1
html ^0.13.2 0.13.2+2
Transitive dependencies
analyzer 0.31.0+1
args 1.3.0
async 2.0.3
charcode 1.1.1
cli_util 0.1.2+1
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
front_end 0.1.0-alpha.8
glob 1.1.5
isolate 1.1.0
kernel 0.3.0-alpha.5
logging 0.11.3+1
meta 1.1.2
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
yaml 2.1.13