converters 0.0.3

  • Example
  • Installing
  • Versions
  • 38


Simple type converters


A simple usage example:

import 'package:converters/converters.dart';

main() {
  var myInt = convertTo(int, '10');
  var myString = convertFrom(int, 10);

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Added handling of dynamic


  • Initial version, created by Stagehand


// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library converters.example;

//import 'package:converters/converters.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  converters: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:converters/converters.dart';
Version Uploaded Documentation Archive
0.0.3 Apr 10, 2016 Go to the documentation of converters 0.0.3 Download converters 0.0.3 archive
0.0.2 Jan 6, 2016 Go to the documentation of converters 0.0.2 Download converters 0.0.2 archive
0.0.1 Aug 12, 2015 Go to the documentation of converters 0.0.1 Download converters 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:converters/converters.dart.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Fix lib/src/converters_base.dart.

Analysis of lib/src/converters_base.dart reported 2 hints:

line 67 col 8: 'JSON' is deprecated and shouldn't be used.

line 68 col 9: 'JSON' is deprecated and shouldn't be used.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
test >=0.12.0 <0.13.0