cool_bottom_bar 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new56

Cool Bottom Bar #

Inspired by

https://dribbble.com/shots/5925052-Google-Bottom-Bar-Navigation-Pattern

Preview #

https://youtu.be/CxQYiHvQ20s

Usage #

add to pubsec

cool_bar: 0.0.1

import

import 'package:flutter_app/CoolBottomBar.dart';

Example #

import 'package:cool_bar/cool_bar.dart';
import 'package:flutter/material.dart';

class HomePage extends StatefulWidget {
  @override
  _HomePageState createState() => _HomePageState();
}

class _HomePageState extends State<HomePage> {
  int selected = 0;

  List colors = [Colors.deepPurple, Colors.pink, Colors.yellow, Colors.cyan];

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text("Cool Bar"),
        backgroundColor: colors[selected],
      ),
      body: AnimatedContainer(
        duration: Duration(milliseconds: 200),
        color: colors[selected],
      ),
      bottomNavigationBar: CoolBottomBar(
        items: <CoolBarItem>[
          CoolBarItem(
            icon: Icon(Icons.home),
            activeColor: Colors.deepPurple[700],
            backgroundColor: Colors.deepPurple[100],
            title: "Home",
          ),
          CoolBarItem(
            icon: Icon(Icons.favorite_border),
            activeColor: Colors.pink[700],
            backgroundColor: Colors.pink[100],
            title: "Likes",
          ),
          CoolBarItem(
            icon: Icon(Icons.search),
            activeColor: Colors.yellow[700],
            backgroundColor: Colors.yellow[100],
            title: "Search",
          ),
          CoolBarItem(
            icon: Icon(Icons.person),
            activeColor: Colors.cyan[700],
            backgroundColor: Colors.cyan[100],
            title: "Profile",
          )
        ],
        selectedIndex: selected,
        itemClicked: (int index) {
          setState(() {
            selected = index;
          });
        },
      ),
    );
  }
}

[0.0.1] - 2019/02/19

  • initial release a quick and dirty way to do the design

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cool_bottom_bar: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cool_bottom_bar/cool_bottom_bar.dart';
  
Version Uploaded Documentation Archive
0.0.1 Feb 26, 2019 Go to the documentation of cool_bottom_bar 0.0.1 Download cool_bottom_bar 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/cool_bottom_bar.dart.

Run flutter format to format lib/cool_bottom_bar.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cool_bottom_bar.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test