cordova 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new63

Dart Wrapper for Cordova

If you would like to use cordova events in your app, use this package.

import Cordova from this package and you ready to go!

pub package


## installation 

dependencies: cordova: ^1.0.0


## import

import 'package:cordova/cordova.dart';


## supported events
- deviceready
- backbutton
- menubutton
- pause
- resume

[1.0.1] - 2018-12-30

Fixed

  • change source of event listener from window object to document

example/main.dart

import 'package:cordova/cordova.dart';

int counter = 0;
void main() {
  Cordova cordova = new Cordova();
  cordova.isDeviceReady().then((bool isReady) {
    print('device is ready');
  });
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cordova: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cordova/cordova.dart';
  
Version Uploaded Documentation Archive
1.0.1 Dec 30, 2018 Go to the documentation of cordova 1.0.1 Download cordova 1.0.1 archive
1.0.0 Dec 30, 2018 Go to the documentation of cordova 1.0.0 Download cordova 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10

Platforms

Detected platforms: web

Primary library: package:cordova/cordova.dart with components: html.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
build_runner ^1.1.2
build_web_compilers ^0.4.4
test ^1.5.1