cordova_googleplus_plugin 1.0.0

  • README.md
  • Example
  • Installing
  • Versions
  • 63

Dart Wrapper for Cordova Googleplus Plugin #

if you would like to use this plugin: https://github.com/EddyVerbruggen/cordova-plugin-googleplus with dart. Install this package.

In you code just import KeyboardPlugin, and watch the available methods. They are exactly the same like on cordova repo.

Remember to install the cordova plugin also!! this is just a wrapper

pub package: https://pub.dartlang.org/packages/dart_cordova_keyboard_plugin#-readme-tab-

installation: #

add this to your dependencies

dependencies:
  cordova_googleplus_plugin: ^1.0.0

import #

import 'package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart';

example/main.dart

import 'dart:html';

import 'package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart';

String CLIENT_ID = 'your google client it';

void main() {
  GoogleplusPlugin googleplus = GoogleplusPlugin(webClientId: CLIENT_ID);

  googleplus
      .trySilentLogin()
      .then((GoogleplusPayload payload) => print(payload.email));

  document.getElementById('something').onClick.listen((MouseEvent event) {
    googleplus
        .login()
        .then((GoogleplusPayload payload) => print(payload.email));
  });
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cordova_googleplus_plugin: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jan 2, 2019 Go to the documentation of cordova_googleplus_plugin 1.0.1 Download cordova_googleplus_plugin 1.0.1 archive
1.0.0 Jan 2, 2019 Go to the documentation of cordova_googleplus_plugin 1.0.0 Download cordova_googleplus_plugin 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13

Platforms

Detected platforms: web, other

Primary library: package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart with components: js.

Health issues and suggestions

Document public APIs. (-1 points)

31 out of 31 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/cordova_googleplus_plugin.dart.

Run dartfmt to format lib/cordova_googleplus_plugin.dart.

Format lib/src/cordova_googleplus_api.dart.

Run dartfmt to format lib/src/cordova_googleplus_api.dart.

Format lib/src/googleplus_plugin.dart.

Run dartfmt to format lib/src/googleplus_plugin.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
js >=0.6.0 <0.7.0 0.6.1+1