core_mvc 0.1.1

  • Installing
  • Versions
  • 26

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  core_mvc: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:core_mvc/core_mvc.dart';
  
Version Uploaded Documentation Archive
0.1.1 Apr 5, 2016 Go to the documentation of core_mvc 0.1.1 Download core_mvc 0.1.1 archive
0.1.0 Mar 8, 2016 Go to the documentation of core_mvc 0.1.0 Download core_mvc 0.1.0 archive

Analysis

We analyzed this package on May 22, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.54.0
  • pana: 0.11.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
87 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
26
Learn more about scoring.

Platforms

Detected platforms: other

Primary library: package:core_mvc/core_mvc.dart with components: io, mirrors.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 9 errors 31 hints.

    Strong-mode analysis of lib/router.dart failed with the following error:

    line: 49 col: 39
    The return type 'Symbol' isn't a 'LibraryMirror', as defined by anonymous closure.

    Strong-mode analysis of lib/src/application/default_application.dart failed with the following error:

    line: 34 col: 3
    Invalid override. The type of 'DefaultApplication.initializeServer' ('() → Future<dynamic>') isn't a subtype of 'Application.initializeServer' ('() → Future<HttpServer>').

    Similar analysis of the following files failed:

    • lib/src/logger/json_logger.dart (error)
    • lib/src/logger/tty_logger.dart (error)
    • lib/src/router/route.dart (error)
    • lib/src/type/enum.dart (error)
    • lib/application.dart (hint)
    • lib/core_mvc.dart (hint)
    • lib/logger.dart (hint)
    • lib/metadata.dart (hint)
    • lib/src/action_filter/action_filter.dart (hint)
    • lib/src/action_filter/authentication_filter.dart (hint)
    • lib/src/action_filter/authorization_filter.dart (hint)
    • lib/src/action_filter/exceptions.dart (hint)
    • lib/src/action_filter/filter_context.dart (hint)
    • lib/src/action_result/action_result.dart (hint)
    • lib/src/action_result/json_result.dart (hint)
    • lib/src/action_result/result_context.dart (hint)
    • lib/src/action_result/string_result.dart (hint)
    • lib/src/http/http_verb.dart (hint)
    • lib/src/router/router.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use core_mvc.dart.

Dependencies

Package Constraint Resolved Available
Dev dependencies
mockito any
test any