Add this to your package's pubspec.yaml file:
dependencies: core_mvc: ^0.1.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.1||Apr 5, 2016|
|0.1.0||Mar 8, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
lib/router.dart. (-68.99 points)
lib/router.dart failed with 4 errors, 4 hints, including:
line 23 col 52: The method 'isSubclassOf' isn't defined for the class 'DeclarationMirror'.
line 27 col 43: The getter 'instanceMembers' isn't defined for the class 'DeclarationMirror'.
line 39 col 10: The return type 'List' isn't a 'Iterable<Route>', as defined by the method '_getLibraryRoutes'.
line 49 col 39: The return type 'Symbol' isn't a 'LibraryMirror', as defined by anonymous closure.
line 4 col 34: The name Stream is shown, but not used.
lib/src/logger/json_logger.dart. (-57.81 points)
lib/src/logger/json_logger.dart failed with 3 errors:
line 11 col 9: super call must be last in an initializer list (see https://goo.gl/EY6hDP): 'super(level: level, group: group)'.
line 19 col 17: Undefined name 'JSON'.
line 31 col 18: Undefined name 'JSON'.
lib/src/application/default_application.dart. (-26.86 points)
lib/src/application/default_application.dart failed with 1 error, 5 hints, including:
line 34 col 3: Invalid override. The type of 'DefaultApplication.initializeServer' ('() → Future<dynamic>') isn't a subtype of 'Application.initializeServer' ('() → Future<HttpServer>').
line 14 col 51: 'ANY_IP_V4' is deprecated and shouldn't be used.
line 42 col 21: 'SIGINT' is deprecated and shouldn't be used.
line 65 col 33: 'INTERNAL_SERVER_ERROR' is deprecated and shouldn't be used.
line 82 col 41: 'GATEWAY_TIMEOUT' is deprecated and shouldn't be used.
Fix additional 20 files with analysis or formatting issues. (-104.75 points)
Additional issues in the following files:
lib/src/router/route.dart(1 error, 1 hint)
lib/src/type/enum.dart(1 error, 1 hint)
Add SDK constraint in
pubspec.yaml. (-50 points)
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
Fix platform conflicts. (-20 points)
Low code quality prevents platform classification.
Package is too old. (-100 points)
The package was released more than two years ago.
README.md. (-30 points)
Readme should inform others about your project, what it does, and how they can use it.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use