country_code_picker 1.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 45

Pub

country_code_picker #

A flutter package for showing a country code selector.

Usage #

Just put the component in your application setting the onChanged callback.


 @override
  Widget build(BuildContext context) => new Scaffold(
      body: new Center(
        child: new CountryCodePicker(
          onChanged: print,
          // Initial selection and favorite can be one of code ('IT') OR dial_code('+39')
          initialSelection: 'IT',
          favorite: ['+39','FR'],
        ),
      ),
  );

Note: Your onChanged function can be any function of the type shown below:

(CountryCode)->dynamic

Example:


void _onCountryChange(CountryCode countryCode) {
    //Todo : manipulate the selected country code here
    print("New Country selected: " + countryCode.toString());
  }
  

Contributions #

Contributions of any kind are more than welcome! Feel free to fork and improve country_code_picker in any way you want, make a pull request, or open an issue.

0.0.1 #

Initial release

0.0.2 #

Add favorite countries option.

0.1.0 #

Removed flags in iOS because they show up weirdly.

0.1.1 #

Tested with dart 2

0.1.2 #

Favorite and initial selection can be one of code or dial code

0.1.3 #

Favorite and initial selection can be one of code or dial code

0.2.0 #

Now onChanged has a full CElement as argument and not only a string. (issue #4)

0.2.1 #

Added some documentation

0.2.2 #

Added textStyle and padding as widget parameters

1.0.0 #

Use png flags instead of a font

1.0.1 #

Correct README and update screenshots

1.0.2 #

Update framework compatiblity

1.0.3 #

Update flags dimension to reduce application size

1.0.4 #

Update country name with translated version

1.1.0 #

Changed CElement with CountryCode and fix error on favorite null

1.1.1 #

Update allowed dart version and modify description

example/README.md

hello_example #

Demonstrates how to use the hello plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  country_code_picker: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:country_code_picker/country_code_picker.dart';
  
Version Uploaded Documentation Archive
1.1.1 Dec 10, 2018 Go to the documentation of country_code_picker 1.1.1 Download country_code_picker 1.1.1 archive
1.1.0 Nov 22, 2018 Go to the documentation of country_code_picker 1.1.0 Download country_code_picker 1.1.0 archive
1.0.4 Oct 21, 2018 Go to the documentation of country_code_picker 1.0.4 Download country_code_picker 1.0.4 archive
1.0.3 Oct 21, 2018 Go to the documentation of country_code_picker 1.0.3 Download country_code_picker 1.0.3 archive
1.0.2 Aug 24, 2018 Go to the documentation of country_code_picker 1.0.2 Download country_code_picker 1.0.2 archive
1.0.1 Jul 15, 2018 Go to the documentation of country_code_picker 1.0.1 Download country_code_picker 1.0.1 archive
1.0.0 Jul 14, 2018 Go to the documentation of country_code_picker 1.0.0 Download country_code_picker 1.0.0 archive
0.2.2 May 5, 2018 Go to the documentation of country_code_picker 0.2.2 Download country_code_picker 0.2.2 archive
0.2.1 May 5, 2018 Go to the documentation of country_code_picker 0.2.1 Download country_code_picker 0.2.1 archive
0.2.0 May 5, 2018 Go to the documentation of country_code_picker 0.2.0 Download country_code_picker 0.2.0 archive

All 16 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
91
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <=3.0.0