crossfire 2.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 67

crossfire #

Cross-platform APIs for Firebase.

see the project page for usage examples

2.1.0 #

  • add startsAfter

Thanks to @leftyio for this release!

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  crossfire: ^2.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:crossfire/crossfire.dart';
  
Version Uploaded Documentation Archive
2.1.0 Mar 12, 2019 Go to the documentation of crossfire 2.1.0 Download crossfire 2.1.0 archive
2.0.3 Sep 25, 2018 Go to the documentation of crossfire 2.0.3 Download crossfire 2.0.3 archive
2.0.2 Sep 13, 2018 Go to the documentation of crossfire 2.0.2 Download crossfire 2.0.2 archive
2.0.1 Aug 22, 2018 Go to the documentation of crossfire 2.0.1 Download crossfire 2.0.1 archive
2.0.0+2 Sep 13, 2018 Go to the documentation of crossfire 2.0.0+2 Download crossfire 2.0.0+2 archive
2.0.0+1 Aug 21, 2018 Go to the documentation of crossfire 2.0.0+1 Download crossfire 2.0.0+1 archive
2.0.0 Aug 21, 2018 Go to the documentation of crossfire 2.0.0 Download crossfire 2.0.0 archive
1.0.0+3 Sep 25, 2018 Go to the documentation of crossfire 1.0.0+3 Download crossfire 1.0.0+3 archive
1.0.0+1 Jul 11, 2018 Go to the documentation of crossfire 1.0.0+1 Download crossfire 1.0.0+1 archive
1.0.0 Jul 11, 2018 Go to the documentation of crossfire 1.0.0 Download crossfire 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Mar 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:crossfire/crossfire.dart.

Health suggestions

Fix lib/src/crossfire_base.dart. (-1.49 points)

Analysis of lib/src/crossfire_base.dart reported 3 hints:

line 28 col 62: Use = to separate a named parameter from its default value.

line 48 col 55: Use = to separate a named parameter from its default value.

line 94 col 55: Use = to separate a named parameter from its default value.

Format lib/crossfire.dart.

Run dartfmt to format lib/crossfire.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and crossfire.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <3.0.0
Dev dependencies
build_runner any
test ^1.3.0