crossfire_flutter 2.0.0+3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 61

crossfire_flutter

Cross-platform APIs for Firebase.

see the project page for usage examples

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  crossfire_flutter: ^2.0.0+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:crossfire_flutter/crossfire_flutter.dart';
  
Version Uploaded Documentation Archive
2.0.0+3 Sep 25, 2018 Go to the documentation of crossfire_flutter 2.0.0+3 Download crossfire_flutter 2.0.0+3 archive
2.0.0+2 Sep 13, 2018 Go to the documentation of crossfire_flutter 2.0.0+2 Download crossfire_flutter 2.0.0+2 archive
2.0.0 Aug 21, 2018 Go to the documentation of crossfire_flutter 2.0.0 Download crossfire_flutter 2.0.0 archive
1.0.0+1 Jul 11, 2018 Go to the documentation of crossfire_flutter 1.0.0+1 Download crossfire_flutter 1.0.0+1 archive
1.0.0 Jul 11, 2018 Go to the documentation of crossfire_flutter 1.0.0 Download crossfire_flutter 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Nov 17, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/crossfire_flutter.dart. (-25.38 points)

Analysis of lib/crossfire_flutter.dart failed with 1 error, 1 hint:

line 292 col 23: The getter 'future' isn't defined for the class 'StorageUploadTask'.

line 54 col 18: 'enablePersistence' is deprecated and shouldn't be used.

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: firebase_auth.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use crossfire_flutter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
cloud_firestore ^0.8.0 0.8.2+3
crossfire ^2.0.0 2.0.3
firebase_auth 0.6.2+1
firebase_core ^0.2.5 0.2.5+1
firebase_database ^1.0.4 1.0.5
firebase_storage ^1.0.2 1.0.4
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test