Cross-platform APIs for Firebase.
see the project page for usage examples
Add this to your package's pubspec.yaml file:
dependencies: crossfire_flutter: ^2.0.0+3
You can install packages from the command line:
$ flutter packages get
Alternatively, your editor might support
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|2.0.0+3||Sep 25, 2018|
|2.0.0+2||Sep 13, 2018|
|2.0.0||Aug 21, 2018|
|1.0.0+1||Jul 11, 2018|
|1.0.0||Jul 11, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/crossfire_flutter.dart. (-25.38 points)
lib/crossfire_flutter.dart failed with 1 error, 1 hint:
line 292 col 23: The getter 'future' isn't defined for the class 'StorageUploadTask'.
line 54 col 18: 'enablePersistence' is deprecated and shouldn't be used.
Document public APIs. (-1 points)
70 out of 70 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.
Use constrained dependencies. (-20 points)
pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies:
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
|Dart SDK||>=2.0.0 <3.0.0|