csharp_parser 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

csharp_parser

experimental C# parser done mostly to learn how to create parsers... based on awesome http://www.craftinginterpreters.com

Current main purpose is converting POCOs to PODOs (plain old C#/Dart object) files

Warning! It's not production ready

Usage

var scanner = new Scanner(sourceCode);
scanner.scanTokens();
print('is error: ${scanner.hadError}');
Parser parser = new Parser(scanner.tokens);
 
List<Stmt> statements = parser.parse();
//now statements contains AST tree

Features and bugs

Recognizes namespace class, properties, methods

Current limitations

  • ignores method bodies
  • does not support conditional expressions
  • does not support namespace aliases in using directive

Changelog

0.0.2

  • ignore attributes

0.0.1

  • Initial version, created by Stagehand

0.0.4

  • Attributes on classes

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  csharp_parser: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:csharp_parser/csharp_parser.dart';
  
Version Uploaded Documentation Archive
0.0.4 Oct 20, 2017 Go to the documentation of csharp_parser 0.0.4 Download csharp_parser 0.0.4 archive
0.0.3 Oct 16, 2017 Go to the documentation of csharp_parser 0.0.3 Download csharp_parser 0.0.3 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0