cssembed 0.2.0+5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

cssembed

Embeds css into polymer elements.

Requirements

  • Polymer 1.0

Usage

Add cssembed to pubspec.yaml before polymer transformer:

transformers:
- cssembed
- polymer:
    entry_points: web/index.html
- $dart2js:
    minify: true
    commandLineOptions:
    - --trust-type-annotations
    - --trust-primitives
    

Stylesheets must have the same name of the polymer element and must be placed in the same directory.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.2.0+5

  • Updated example.

0.2.0+4

  • Renamed transformer.dart to cssembed.dart.

0.2.0+3

  • Edited before publishing to pub.

0.2.0+2

  • Rewritten changelog. Homepage added.

0.2.0+1

  • Removed unnecessary print.

0.2.0

  • Now css is embedded into existing style tag.

0.1.0

  • First working version.

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cssembed: ^0.2.0+5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cssembed/cssembed.dart';
  
Version Uploaded Documentation Archive
0.2.0+5 Mar 18, 2016 Go to the documentation of cssembed 0.2.0+5 Download cssembed 0.2.0+5 archive
0.2.0+4 Mar 18, 2016 Go to the documentation of cssembed 0.2.0+4 Download cssembed 0.2.0+4 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0