ctrl_alt_foo2 0.4.0

  • README.md
  • Installing
  • Versions
  • 0

Ctrl Alt Foo

Build Status

Make it easy to listen for keyboard shortcuts / accelator keys.

Usage

This is an early preview release and the syntax is not settled. Please add issues in the tracker if you have suggestions.

import 'package:ctrl_alt_foo2/keys.dart';

Keys.shortcuts({
  'Esc':          (){ _hideMenu(); _hideDialog(); },
  'Ctrl+N':       ()=> new NewProjectDialog(this).open(),
  'Ctrl+O, ⌘+O':  ()=> new OpenDialog(this).open(),
  'Ctrl+Shift+H': ()=> toggleCode()
});

There are also some helper methods for creating keyboard events:

import 'package:ctrl_alt_foo2/helpers.dart';

typeIn('TEXT'); // will generate a keyup

hitEnter();
hitEscape();

arrowUp(); // optionally supply the number of time to arrow up
arrowDown();

type('A'); // type a single character
typeCtrl('A'); // type Ctrl+A
typeCtrlShift('A'); // type Ctrl+Shift+A

LICENSE

This code is licensed under the MIT license. See LICENSE for more information.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ctrl_alt_foo2: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ctrl_alt_foo2/helpers.dart';
import 'package:ctrl_alt_foo2/key_event_x.dart';
import 'package:ctrl_alt_foo2/key_identifier.dart';
import 'package:ctrl_alt_foo2/keys.dart';
import 'package:ctrl_alt_foo2/shortcut.dart';
  
Version Uploaded Documentation Archive
0.4.0 Jul 5, 2018 Go to the documentation of ctrl_alt_foo2 0.4.0 Download ctrl_alt_foo2 0.4.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK 2.0.0-dev.67.0