cupertino_segment_control 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 31

cupertino_segment_control #

A flutter package which adds the Apple's iOS Segment Control UI element.

Getting Started #

  • Add the package to your pubspec
  • Add following code:
      new SegmentControl([
          new SegmentControlItem("test1", new Text("test1")),
          new SegmentControlItem("test2", new Text("test2")),
          new SegmentControlItem("test3", new Text("test3")),
      ]),
    

PS: minimum of 1 SegmentControlItem and maximum of 3 SegmentControlItem due to this bug: https://github.com/flutter/flutter/issues/12583

Showcase #

[0.0.3] - Readme instructions changed

  • Readme changes

[0.0.2] - Refactor

  • Refactored class naming

[0.0.1] - Initial release

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cupertino_segment_control: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cupertino_segment_control/cupertino_segment_control.dart';
  
Version Uploaded Documentation Archive
0.0.3 Oct 19, 2017 Go to the documentation of cupertino_segment_control 0.0.3 Download cupertino_segment_control 0.0.3 archive
0.0.2 Oct 19, 2017 Go to the documentation of cupertino_segment_control 0.0.2 Download cupertino_segment_control 0.0.2 archive
0.0.1 Oct 17, 2017 Go to the documentation of cupertino_segment_control 0.0.1 Download cupertino_segment_control 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.