cupertino_segment_control 0.0.3

  • Installing
  • Versions
  • 84


A flutter package which adds the Apple's iOS Segment Control UI element.

Getting Started

  • Add the package to your pubspec
  • Add following code:
      new SegmentControl([
          new SegmentControlItem("test1", new Text("test1")),
          new SegmentControlItem("test2", new Text("test2")),
          new SegmentControlItem("test3", new Text("test3")),

PS: minimum of 1 SegmentControlItem and maximum of 3 SegmentControlItem due to this bug:


[0.0.3] - Readme instructions changed

  • Readme changes

[0.0.2] - Refactor

  • Refactored class naming

[0.0.1] - Initial release

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  cupertino_segment_control: "^0.0.3"

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:cupertino_segment_control/cupertino_segment_control.dart';
Version Uploaded Documentation Archive
0.0.3 Oct 19, 2017 Go to the documentation of cupertino_segment_control 0.0.3 Download cupertino_segment_control 0.0.3 archive
0.0.2 Oct 19, 2017 Go to the documentation of cupertino_segment_control 0.0.2 Download cupertino_segment_control 0.0.2 archive
0.0.1 Oct 17, 2017 Go to the documentation of cupertino_segment_control 0.0.1 Download cupertino_segment_control 0.0.1 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4


Describes how popular the package is relative to other packages. [more]
68 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use cupertino_segment_control.dart.


Package Constraint Resolved Available
Direct dependencies
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.10
meta 1.1.5
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6 2.0.7
Dev dependencies
test ^0.12.0