currency_icons 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 72

currency-icons

A Dart package with many currency icons.

How to use?

Image.asset('icons/currency/${currency}.png', package: 'currency_icons');

Credits

All icons are used from transferwise

This package is inspired from country_icons

0.1.0

  • Add example
  • Specify only for flutter
  • Specify Dart 2 only

0.0.1

  • Add currency icons

example/main.dart

import 'package:flutter/material.dart';

class Currency extends StatelessWidget {
  // init Currency
  final String currencyName;

  Currency({Key key, @required this.currencyName}) : super(key: key);

  @override
  Widget build(BuildContext context) {
    return new Card(
      child: new Column(
        mainAxisSize: MainAxisSize.min,
        children: <Widget>[
          ListTile(
              leading: Image.asset('icons/currency/${this.currencyName}.png',
                  package: 'currency_icons'),
              title: Text(this.currencyName)),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  currency_icons: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.2 Jul 23, 2018 Go to the documentation of currency_icons 0.0.2 Download currency_icons 0.0.2 archive
0.0.1 Jul 12, 2018 Go to the documentation of currency_icons 0.0.1 Download currency_icons 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3
  • Flutter: 0.8.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.55.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_launcher_icons ^0.5.2
flutter_test