currency_input_formatter 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 24

currency_input_formatter

A custom Flutter TextInputFormatter for currency values.

Demo

Usage

Initialize it in the inputFormatters parameter of a TextField or TextFormField.

Currently, there are two parameters:

allowSubdivisions - Whether or not to allow non-whole number values.
subdivisionMarker - The string separator in between the whole number and subdivision parts of a currency value.

Short Example

new TextField(
    autofocus: true,
    keyboardType: TextInputType.number,
    decoration: const InputDecoration(
        labelText: "Salary",
        prefixText: '\$',
    ),
    inputFormatters: <TextInputFormatter>[
      new CurrencyInputFormatter(
          allowSubdivisions: true,
          subdivisionMarker: "."
      ),
    ],
),

[0.0.5] - 21 March 2018

  • Add gif demo to README

[0.0.4] - 21 March 2018

  • Add example to README
  • Add keyboard type to example

[0.0.3] - 20 March 2018

  • Fixed formatting in main file
  • Added example

[0.0.2] - 20 March 2018

  • Didn't actually work. Fixed the regexes.

[0.0.1] - 20 March 2018

  • Initial release
  • Basic customizations and safeguards.

example/example.dart

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:currency_input_formatter/currency_input_formatter.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
        title: "Currency Formatter",
        home: new Scaffold(
            appBar: new AppBar(title: new Text("Currency Formatter")),
            body: new ListView(
                padding: const EdgeInsets.symmetric(horizontal: 16.0),
                children: <Widget>[
                  new TextField(
                      autofocus: true,
                      keyboardType: TextInputType.number,
                      decoration: const InputDecoration(
                          labelText: "Salary",
                          prefixText: '\$',
                      ),
                      inputFormatters: <TextInputFormatter>[
                        new CurrencyInputFormatter(
                            allowSubdivisions: true,
                            subdivisionMarker: "."
                        ),
                      ],
                  ),
                ],
            ),
        ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  currency_input_formatter: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:currency_input_formatter/currency_input_formatter.dart';
  
Version Uploaded Documentation Archive
0.0.5 Mar 20, 2018 Go to the documentation of currency_input_formatter 0.0.5 Download currency_input_formatter 0.0.5 archive
0.0.4 Mar 20, 2018 Go to the documentation of currency_input_formatter 0.0.4 Download currency_input_formatter 0.0.4 archive
0.0.3 Mar 20, 2018 Go to the documentation of currency_input_formatter 0.0.3 Download currency_input_formatter 0.0.3 archive
0.0.2 Mar 20, 2018 Go to the documentation of currency_input_formatter 0.0.2 Download currency_input_formatter 0.0.2 archive
0.0.1 Mar 20, 2018 Go to the documentation of currency_input_formatter 0.0.1 Download currency_input_formatter 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
24
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0