d_components 0.0.22

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

A web app that uses AngularDart Components

Generated by Stagehand. See LICENSE.

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  d_components: ^0.0.22

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:d_components/d_components.dart';
  
Version Uploaded Documentation Archive
0.0.22 Oct 19, 2017 Go to the documentation of d_components 0.0.22 Download d_components 0.0.22 archive
0.0.21 Oct 19, 2017 Go to the documentation of d_components 0.0.21 Download d_components 0.0.21 archive
0.0.20 Oct 19, 2017 Go to the documentation of d_components 0.0.20 Download d_components 0.0.20 archive
0.0.19 Sep 9, 2017 Go to the documentation of d_components 0.0.19 Download d_components 0.0.19 archive
0.0.18 Sep 1, 2017 Go to the documentation of d_components 0.0.18 Download d_components 0.0.18 archive
0.0.17 Aug 31, 2017 Go to the documentation of d_components 0.0.17 Download d_components 0.0.17 archive
0.0.16 Aug 31, 2017 Go to the documentation of d_components 0.0.16 Download d_components 0.0.16 archive
0.0.15 Aug 29, 2017 Go to the documentation of d_components 0.0.15 Download d_components 0.0.15 archive
0.0.14 Aug 29, 2017 Go to the documentation of d_components 0.0.14 Download d_components 0.0.14 archive
0.0.12 Aug 26, 2017 Go to the documentation of d_components 0.0.12 Download d_components 0.0.12 archive

All 20 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0