dabi 0.1.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new46

DaBi

Dart library for binding map values to Dart classes. Only for Linux Dart VM apps.

Tasks

  • [ ] Optional type checks
  • [ ] Binding nested maps

0.1.0

  • Initial release.

example/example.dart

import 'package:dabi/dabi.dart';

class Person {
  String first;
  String last;
  List<String> emails;

  String toString() => '$first $last';
}

void main() {
  Person person = bind({'first': 'John', 'last': 'Doe', 'emails': ['info@mail']}, Person);
  print(person);
  print(person.emails);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dabi: ^0.1.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dabi/dabi.dart';
  
Version Uploaded Documentation Archive
0.1.5 Nov 21, 2018 Go to the documentation of dabi 0.1.5 Download dabi 0.1.5 archive
0.1.4 Nov 21, 2018 Go to the documentation of dabi 0.1.4 Download dabi 0.1.4 archive
0.1.2 Nov 21, 2018 Go to the documentation of dabi 0.1.2 Download dabi 0.1.2 archive
0.1.1 Nov 21, 2018 Go to the documentation of dabi 0.1.1 Download dabi 0.1.1 archive
0.1.0 Nov 21, 2018 Go to the documentation of dabi 0.1.0 Download dabi 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: other

Primary library: package:dabi/dabi.dart with components: nativewrappers.

Health issues and suggestions

Document public APIs (-10 points)

2 out of 2 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance issues and suggestions

Homepage does not exists. (-20 points)

We were unable to access https://github.com/ykmnkmi/dabi at the time of the analysis.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test ^1.0.0