darequest 0.2.2

  • README.md
  • Installing
  • Versions
  • 15


dart request lib

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  darequest: ^0.2.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:darequest/exceptions/response_exception.dart';
import 'package:darequest/interceptor/interceptor.dart';
import 'package:darequest/request.dart';
import 'package:darequest/request_option.dart';
import 'package:darequest/response.dart';
Version Uploaded Documentation Archive
0.2.2 Mar 9, 2018 Go to the documentation of darequest 0.2.2 Download darequest 0.2.2 archive
0.2.1 Mar 8, 2018 Go to the documentation of darequest 0.2.1 Download darequest 0.2.1 archive
0.2.0 Mar 8, 2018 Go to the documentation of darequest 0.2.0 Download darequest 0.2.0 archive
0.1.0 Mar 8, 2018 Go to the documentation of darequest 0.1.0 Download darequest 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3


Detected platforms: unsure

Low code quality prevents platform classification.

Issues and suggestions

Fix platform conflicts.

Low code quality prevents platform classification.

Fix lib/request.dart.

Analysis of lib/request.dart failed with 4 errors, 2 hints, including:

line 67 col 20: Undefined name 'JSON'.

line 119 col 16: The return type 'Future' isn't a 'FutureOr<Response<StreamedResponse>>', as defined by anonymous closure.

line 162 col 46: Undefined name 'UTF8'.

line 178 col 14: Undefined name 'JSON'.

line 2 col 8: Unused import: 'dart:convert'.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use darequest.dart.

Fix lib/exceptions/response_exception.dart.

Analysis of lib/exceptions/response_exception.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:io'.

Format lib/interceptor/interceptor.dart.

Run dartfmt to format lib/interceptor/interceptor.dart.

Format lib/request_option.dart.

Run dartfmt to format lib/request_option.dart.

Fix lib/response.dart.

Analysis of lib/response.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:io'.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <=2.0.0
http ^0.11.3+16 0.11.3+17
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6