dart2_fix 1.0.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 53

Build Status

A tool to migrate API usage to Dart 2.

What does it do?

dart2_fix is a command line utility that can automatically migrate some Dart 1 API usages in your source code to Dart 2 ones. Currently, it focuses on updating deprecated constant names; for example:

  • update dart:convert's UTF8 to utf8
  • update dart:core's Duration.ZERO to Duration.zero
  • update dart:math's PI to pi

For more information about preparing your code for Dart 2, please see the Dart 2 migration guide.

How do I use it?

To install, run pub global activate dart2_fix. Then, from your project directory, run:

pub global run dart2_fix

When run without any arguments, it will check your project, but will not make changes; it'll indicate what would be changed if asked to make modifications. For example:

test/test/runner/load_suite_test.dart
  line 56 • Duration.ZERO => Duration.zero
  line 60 • Duration.ZERO => Duration.zero
  line 86 • Duration.ZERO => Duration.zero

test/tool/host.dart
  line 169 • JSON => json
  line 173 • JSON => json

Found 5 fixes in 2.3s.

To apply these fixes, run again using the --apply argument.

To actually modify your project source code, run with the --apply argument (pub global run dart2_fix --apply):

Updating test...

test/test/runner/load_suite_test.dart
  3 fixes applied for Duration.ZERO => Duration.zero

test/tool/host.dart
  2 fixes applied for JSON => json

Applied 5 fixes in 1.9s.

What about Flutter code?

To run this tool on Flutter code, use:

flutter packages pub global activate dart2_fix

then - to check your code - run:

flutter packages pub global run dart2_fix

and to apply fixes, run:

flutter packages pub global run dart2_fix --apply

Will this make all of my code Dart 2 compliant?

No. Currently this only fixes the renaming of various deprecated constant names. Some of the less uniform constant renamings are not handled by this tool. For example Endianness.BIG_ENDIAN has been renamed to Endian.big but this will not be caught. After running this tool, remaining issues can be found by running the dart analyzer (or flutter analyze) and fixing any deprecation warnings.

I'm getting new static (or runtime errors) after running dart2_fix, what went wrong?

This tool can't catch conflicts between the new constant names and any fields or local variables that you might have in scope. If you get new analysis warnings or runtime failures after running this tool, check to see whether one of the changes made has caused a naming conflict with something else in scope. The most common cause of this is having a local variable named json in a scope where JSON.decode gets renamed to json.decode. To help with fixing these kinds of conflicts, the following top level members have been added to dart:convert: jsonDecode, jsonEncode, base64Decode, base64Encode, and base64UrlEncode. These top level members are equivalent to json.decode, json.decode, etc, and can be used to avoid naming conflicts where required.

Features and bugs

Please file feature requests and bugs at the issue tracker.

1.0.6

  • Upgraded dependencies for Dart 2.

1.0.5

  • Support more constants related to HTTP.

1.0.4

  • Add support for removing @proxy annotations.
  • Convert JSON.encode references to jsonEncode (and similarly for jsonDecode, base64Encode, and base64Decode).

1.0.3

  • Add support for deprecated dart:io constants.

1.0.2

  • Add a dart2_fix pub run entry-point.
  • Updates to the latest version of packages.
  • Added an --check-package=<package name> option.

1.0.1

  • Made the tool work under Dart 2 runtime semantics.
  • Updated when we print timing info for the tool.
  • Added an SDK lower bound of 2.0.0-dev.36.0.
  • Added a --verbose flag.

1.0.0+2

  • Fix an issue converting DateTime.AUGUST.

1.0.0+1

  • Fix an issue converting double.INFINITY.

1.0.0

  • Initial version.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dart2_fix

2. Use it

The package has the following executables:


$ dart2_fix
Version Uploaded Documentation Archive
1.0.6 Jul 22, 2018 Go to the documentation of dart2_fix 1.0.6 Download dart2_fix 1.0.6 archive
1.0.5 Jun 20, 2018 Go to the documentation of dart2_fix 1.0.5 Download dart2_fix 1.0.5 archive
1.0.4 May 17, 2018 Go to the documentation of dart2_fix 1.0.4 Download dart2_fix 1.0.4 archive
1.0.3 May 10, 2018 Go to the documentation of dart2_fix 1.0.3 Download dart2_fix 1.0.3 archive
1.0.2 May 4, 2018 Go to the documentation of dart2_fix 1.0.2 Download dart2_fix 1.0.2 archive
1.0.1 Apr 3, 2018 Go to the documentation of dart2_fix 1.0.1 Download dart2_fix 1.0.1 archive
1.0.0+2 Mar 29, 2018 Go to the documentation of dart2_fix 1.0.0+2 Download dart2_fix 1.0.0+2 archive
1.0.0+1 Mar 28, 2018 Go to the documentation of dart2_fix 1.0.0+1 Download dart2_fix 1.0.0+1 archive
1.0.0 Mar 28, 2018 Go to the documentation of dart2_fix 1.0.0 Download dart2_fix 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
7
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dart2_fix.dart.

Fix lib/src/deprecation_analysis_server.dart.

Analysis of lib/src/deprecation_analysis_server.dart reported 1 hint:

line 34 col 10: The value of the local variable 'hadServerError' isn't used.

Fix lib/src/deprecation_analyzer.dart.

Analysis of lib/src/deprecation_analyzer.dart reported 1 hint:

line 35 col 17: 'locateContexts' is deprecated and shouldn't be used.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.17.0 <3.0.0
analysis_server_lib ^0.1.4 0.1.4+2
analyzer ^0.32.0 0.32.4
args ^1.4.0 1.5.0
cli_util ^0.1.2 0.1.3+2
intl ^0.15.0 0.15.7
path ^1.5.0 1.6.2
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.14.4+1
front_end 0.1.4
glob 1.1.7
html 0.13.3+2
kernel 0.3.4
logging 0.11.3+2
meta 1.1.6
package_config 1.0.5
plugin 0.2.0+3
source_span 1.4.1
string_scanner 1.0.3
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
yaml 2.1.15
Dev dependencies
test ^1.0.0