dart2_tryparse 1.0.1+dart2

  • README.md
  • Installing
  • Versions
  • new50


Dart 1 polyfills for Dart 2 tryParse() methods


  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart2_tryparse: "^1.0.1+dart2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:dart2_tryparse/dart2_tryparse.dart';
Version Uploaded Documentation Archive
1.0.1+dart2 Jun 14, 2018 Go to the documentation of dart2_tryparse 1.0.1+dart2 Download dart2_tryparse 1.0.1+dart2 archive
1.0.1+dart1 Jun 14, 2018 Go to the documentation of dart2_tryparse 1.0.1+dart1 Download dart2_tryparse 1.0.1+dart1 archive
1.0.0+dart1 Jun 14, 2018 Go to the documentation of dart2_tryparse 1.0.0+dart1 Download dart2_tryparse 1.0.0+dart1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dart2_tryparse/dart2_tryparse.dart.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use dart2_tryparse.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.34.0 <2.0.0
Dev dependencies
test ^0.12.0