dart_actor 0.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new66

dart_actor #

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:dart_actor/dart_actor.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_actor: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_actor/dart_actor.dart';
  
Version Uploaded Documentation Archive
0.0.5 Feb 10, 2019 Go to the documentation of dart_actor 0.0.5 Download dart_actor 0.0.5 archive
0.0.4 Feb 9, 2019 Go to the documentation of dart_actor 0.0.4 Download dart_actor 0.0.4 archive
0.0.3 Feb 8, 2019 Go to the documentation of dart_actor 0.0.3 Download dart_actor 0.0.3 archive
0.0.2 Feb 8, 2019 Go to the documentation of dart_actor 0.0.2 Download dart_actor 0.0.2 archive
0.0.1 Jan 29, 2019 Go to the documentation of dart_actor 0.0.1 Download dart_actor 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
87
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dart_actor/dart_actor.dart.

Health issues and suggestions

Document public APIs. (-1 points)

93 out of 93 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/actor_context.dart. (-1 points)

Analysis of lib/src/actor_context.dart reported 2 hints:

line 47 col 12: Use isNotEmpty for Iterables and Maps.

line 50 col 11: Use isNotEmpty instead of length

Fix lib/src/listener.dart. (-0.50 points)

Analysis of lib/src/listener.dart reported 1 hint:

line 5 col 28: Don't explicitly initialize variables to null.

Format lib/src/root_actor.dart.

Run dartfmt to format lib/src/root_actor.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and dart_actor.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
event_bus ^1.0.1 1.0.3
uuid ^1.0.1 1.0.3 2.0.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
typed_data 1.1.6
Dev dependencies
test ^1.5.1+1